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Membuat situs sederhana dengan Dreamweaver*) 
Oleh: 

Sri Andayani 

Jurusan Pendidikan Matematika, FMIPA UNY 

 

Dreamweaver merupakan salah satu perangkat lunak bantu dalam kelompok 

Macromedia yang digunakan untuk mengembangkan sebuah halaman web.  

Langkah-langkah untuk membuat situs sederhana sebagai berikut: 

1. Membuat folder utama yang akan diisi dengan semua file yang dibutuhkan 

untuk membuat situs 

2. Mendefinisikan situs 

3. Membuat file index.html dan file-file lain yang dibutuhkan untuk hyperlink 

4. Mempublish situs 

 

Berikut ini akan ditunjukkan langkah-langkah membuat situs sederhana dengan 

menggunakan bahan-bahan (file gambar, video, teks) yang telah disediakan oleh 

Macromedia Dreamweaver 8 dalam folder  cafe_townsend. 

1. Membuat folder utama  

Saat membuat situs lokal, semua file yang dibutuhkan (gambar, text, video dll) harus 

diletakkan di sebuah folder lokal (folder utama untuk situs tsb).  

1. Buatlah folder baru dengan nama local_sites di drive E.  

2. Buka C:\Program Files\Macromedia\Dreamweaver 8\Tutorial_assets\ 

cafe_townsend\.  

3. Copy folder cafe_townsend ke dalam folder local_sites.  

Folder cafe_townsend adalah folder yang akan digunakan sebagai folder utama 

(main folder) untuk situs lokal yang akan dibuat. 

 

 
Gambar 1. Folder local_site berisi folder café_townsend 

 

                                                 
*) Disampaikan pada Pelatihan Pembuatan Sumber Belajar Matematika Berbasis Web dengan 
Menggunakan Perangkat Lunak Macromedia Dreamweaver bagi Guru Sekolah Menengah di DIY, 
Jurusan Pendidikan Matematika FMIPA UNY, 8-9 Agustus 208 
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2. Mendefinisikan situs  

Setelah menyiapkan folder tempat menyimpan semua file yang akan digunakan 

untuk membuat situs, langkah selanjutnya adalah mendefinisikan situs yang akan 

dibuat.  

Untuk mendefinisikan situs, mulailah dengan membuka program macromedia 

Dreamweaver 8, melalui Start  All Programs  Macromedia  Macromedia 

Dreamweaver 8.  

1. Pilih menu Site  Manage Sites. Muncul kotak dialog Manage Sites, seperti 

gambar 2. 

 
Gambar 2. Kotak dialog Manage Sites 

1. Klik Tombol New, pilih site . Kotak Site Definition akan tampil, seperti tampak 

dalam gambar 3. 

 
Gambar 3. Kotak dialog untuk mendefinisikan situs 

2. Klik tabulasi Advanced dan pilih Local Info dari daftar Category  
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3. Pada kotak Site Name, ketikkan Cafe Townsend sebagai nama situs  

4. Pada kotak Local Root Folder, klik tombol browse untuk menentukan folder  

cafe_townsend yang berada dalam folder local_sites, sehingga berisi 

E:\local_site\cafe_townsend\ 

5. Pada kotak Default Images Folder, tentukan folder yang berisi images, yaitu 

E:\local_site\cafe_townsend\images\ 

6. Klik OK.  

7. Klik Done untuk menutup kotak dialog Manage Sites.  

 

3. Membuat file index.html  

Setelah mendefinisikan site, langkah selanjutnya adalah membuat file index.html, 

yang merupakan file utama dalam membangun sebuah halaman web.  

1. Pilih menu File  New.  

 
Gambar 4. Kotak dialog New Document 

2. Pada tabulasi General, pilih Basic Page pada daftar Category, pilih HTML pada 

daftar Basic Page, dan klik tombol Create.  

3. Pilih File  Save As. Pada kotak save in, tentukan folder untuk menyimpan 

berada pada jalur  E:\local_site\cafe_townsend\  

4. Simpan dengan nama index.html. Klik tombol Save. 

5. Klik pada kotak Document Title text di bagian atas jendela, ketikkan Cafe 

Townsend (lihat gambar 5)  
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Gambar 5. Kotak Document Title diisi dengan teks ’Cafe Townsend’  

6. Simpan kembali file index.html dengan Klik tombol Save. 

 

File index.html akan diisi dengan gambar, teks, animasi, dan video seperti tampak 

dalam gambar 6.  

 
Gambar 6. Rancangan isi halaman index.html  

Untuk membuat halaman tersebut, langkah-langkah yang dilakukan adalah: 

a. Membuat tabel dan mengatur propertinya 

b. Memasukkan gambar 

c. Memasukkan animasi flash 

d. Memasukkan video 

e. Memasukkan teks 

 

a.  Membuat tabel dan mengatur propertinya 

1. Klik di pojok kiri atas halaman index.html untuk meletakkan  insertion point  

2. Pilih Insert  Table. Pada kotak dialog Insert Table, masukkan data-data 

sebagai berikut: 

o Ketikkan 3 pada kotak Rows dan 1 pada kotak Column 

o Ketikkan 700 pada kotak Table Width.  

o Pilih Pixels pada menu pop-up Table Width.  

o Ketikkan 0 pada kotak Border Thickness, Cell Padding dan Cell Spacing  
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Gambar 7. Pengaturan pada kotak dialog Insert Table 

3. Klik OK.  

Pada halaman index.html akan muncul tabel 3 baris 1 kolom yang tidak memiliki 

border, seperti ditunjukkan dalam gambar 8. 

 
Gambar 8. Hasil pembuatan tabel pertama 

4. Klik di sebelah kanan tabel  

5. Klik Insert  Table untuk memasukkan tabel kedua. Atur isian pada kotak 

dialog sebagai berikut.  

o Ketikkan 1 pada kotak Rows dan 3 pada kotak Column 

o Ketikkan 700 pada kotak Table Width.  

o Pilih Pixels pada menu pop-up Table Width.  

o Ketikkan 0 pada kotak Border Thickness, Cell Padding dan Cell Spacing 

6. Klik OK.  

7. Klik di sebelah kanan tabel  

8. Klik Insert  Table untuk memasukkan tabel ketiga. Atur isian pada kotak 

dialog sebagai berikut.  

o Ketikkan 1 pada kotak Rows dan 1 pada kotak Column 

o Ketikkan 700 pada kotak Table Width.  

o Pilih Pixels pada menu pop-up Table Width.  

o Ketikkan 0 pada kotak Border Thickness, Cell Padding dan Cell Spacing 

9. Klik OK.  
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Ketiga tabel yang telah dimasukkan akan tampak seperti gambar 9. 

 
Gambar 9. Hasil pembuatan tabel  

 

Mengatur properti tabel 

1. Pilih View -> Table Mode -> Expanded Table Mode.  

Saat muncul kotak dialog Getting Started with Expanded Tables Mode, klik OK. 

2. Klik pada baris pertama tabel pertama  

3. Pada  Property inspector (Window > Properties), ketikkan 90 pada kotak Cell 

Height (H) dan tekan enter.  

 
Gambar 10 isian Cell Height pada property inspector  

4. Klik pada baris kedua  

5. Pada  Property inspector, isikan 166 pada kotak Cell Height (H), tekan Enter  

6. Klik pada baris ketiga  

7. Pada Property inspector, isikan 24 pada kotak Cell Height, tekan enter  

8. Klik kolom pertama tabel kedua.  

9. Pada  Property inspector, isikan 140 pada  Cell Width (W), tekan Enter  

10. Klik kolom kedua tabel kedua.  

11. Pada Property inspector, isikan 230 pada Cell Width, tekan Enter  

12. Tentukan lebar (width) kolom ketiga menjadi 330.  

13. klik pada baris terkahir  

14. Pada Property inspector, isikan 24 pada kotak Cell Height dan tekan Enter  

Layout tabel akan menjadi seperti gambar berikut: 
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Gambar 11. Layout tabel setelah pengaturan propertinya 

15. Klik Exit link Expanded Tables Mode di bagian atas jendela Document  

16. Simpan kembali halaman index.html.  

Memasukkan image placeholder 

Image placeholder adalah grafik yang digunakan sampai dengan grafik atau gambar 

akhir siap digunakan dalam halaman web. Image placeholder sangat bermanfaat dalam 

menyiapkan tata letak halaman web yang berisi gambar, sebelum gambar yang akan 

digunakan benar-benar siap.  

1. Klik dalam baris pertama tabel pertama  

2. Pilih Insert > Image Objects > Image Placeholder.  

3. Pada kotak Image Placeholder, isikan berikut ini::  

o ketik banner_graphic pada kotak Name.  

o Isikan  700 pada kotak Width dan 90 pada kotak Height.  

o Klik kotak color box dan pilih warna pada color picker. Pilih reddish 

brown (#993300).  

4. Klik OK.  

5. Simpan halaman web tersebut, File   save.  

Memberi warna pada halaman  

1. Klik di dalam sel pertama pada tabel kedua yang teridiri dari 3 kolom  

2. Klik tag <td> di bagian kiri bawah untuk memilih sel tersebut.  

3. Pada Property inspector (Window > Properties), klik di dalam kotak Background 

Color .  

The text box is located directly next to the Background Color (Bg) color box. 

4. Pada kotak Background Color, isikan bilangan hexadecimal #993300 dan tekan 

Enter. Maka warna sel akan menjadi coklat kemerahan  
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Gambar 12. Isian Background pada property inspector  

5. Klik pada sel kedua  

6. Klik <td>  

7. Pada Property inspector, klik pada kotak Background Color, isikan  #F7EEDF, 

dan tekan Enter.  

8. Atur warna sel ketiga sama dengan sel kedua  

9. Klik di luar sel tersebut 

Sekarang warna background halaman akan diubah melalui page properties.  

1. Pilih Modify -> Page Properties.  

2. Pada kategori Appearance dari Page Properties, klik Background Color dan pilih 

warna hitam.  

 
Gambar 13. Pengaturan background color pada page properties  

3. Klik OK.  

4. Simpan kembali halaman web tersebut. 

 

Mengisi image placeholder 

1. Dobel-klik image placeholder, banner_graphic, pada bagian atas halaman.  

2. Pada kotak Select Image Source, cari folder images yang berada dalam folder 

cafe_townsend.  
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3. Pilih file banner_graphic.jpg dan klik OK.  

 
Gambar 14. Pemilihan file banner_graphic.jpg  

 

Dreamweaver akan mengganti image placeholder dengan gambar seperti dalam 

gambar 15. 

 
Gambar 15. Gambar yang mengisi image placeholder  

4. Simpan (File -> Save).  

Selain menggunakan image placeholder, sebuah gambar dapat langsung dimasukkan ke 

halaman web dengan menggunakan menu insert.  

1. Klik pada kolom kedua, tabel kedua 

2. Pada Property inspector (Window > Properties), pilih Center pada pop-up menu 

Horz, dan pilih Top pop-up menu Vert. 

 
Gambar 16. Pengaturan perataan kolom kedua tabel kedua  

3. Tekan tomobl enter sekali untuk memberi ruang kosong di bagian atas sel 

4. Pilih insert  images.  

5. Pada kotak Select Image Source, cari folder images yang berada dalam folder 

cafe_townsend.  

6. Pilih file street_sign.jpg dan klik OK 
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Memasukkan dan menjalankan file Flash  

File Flash yang akan dimasukkan adalah flexible messaging area--or file FMA— 

1. Klik di baris kedua pada tabel pertama  

2. Pada Property inspector (Window > Properties), pilih Center pada menu pop-up 

Horz dan pilih Middle pada menu pop-up Vert.  

 
Gambar 17. Pengaturan perataan baris kedua tabel pertama  

 

3. Pilih Insert -> Media -> Flash.  

4. Pada kotak Select File, pilih file flash_fma.swf, dan klik OK 

 
Gambar 18. Pemilihan file flash_fma.swf 

 

5. Saat kotak Object Tag Accessibility Attributes muncul, klik OK. 

6. Pada Property inspector (Window > Properties), klik Play.  

 
Gambar 19. Klik tombol Play pada property inspector  

 

Dreamweaver akan menjalankan file Flash tersebut, tampilannya seperti 

ditunjukkan dalam gambar 20. 
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Gambar 20. Tampilan file flash_fma.swf 

7. Pada Property inspector, klik Stop untuk berhenti 

8. Simpan kembali file index.html.  

Memasukkan file Flash Video 

1. Klik di atas gambar street_sign.jpg dalam kolom kedua pada tabel kedua  

 
Gambar 21. Insertion poin berada pada kolom kedua tabel kedua 

2. Pilih Insert -> Media -> Flash Video.  

3. Pada kotak Insert Flash Video, pilih Progressive Download Video dari pop-up 

menu Video type.  

4. Pada kotak URL text box, klik browse untuk menentukan folder yang berisi file 

cafe_townsend_home.flv,  

5. Pilih Halo Skin 2 pada pop-up menu Skin.  

6. Pada kotak Width isi 180 dan pada kotak Height isikan 135.  

 
Gambar 22. Pengaturan isi kotak dialog Insert Flash Video 
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7. Klik OK  

8. Simpan kembali index.html.  

 

Memasukkan body text 

1. Pada panel Files, dobel klik file sample_text.txt untuk  membukanya. Cara lain 

adalah memilih menu File  Open , cari file tersebut (di folder cafe_townsend)  

 
Gambar 23. Isi  file sample_text.txt 

2. Tekan tombol Control+A untuk memilih seluruh teks. Pilih Edit -> Copy untuk 

mengcopy teks.  

3. Tutup file sample_text.txt  

4. Pada halaman index.html, klik di kolom ketiga tabel kedua (tabel yang berisi 3 

kolom)  

5. Pilih Edit -> Paste.  

 
Gambar 24. Tampilan halaman web setelah diisi body text 

6. Pada Property inspector (Window > Properties), pilih Top dari pop-up menu 

Vert.  

7. Simpan kembali index.html 
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Memasukkan teks navigasi 

Teks navigasi adalah teks yang memuat link, yang akan mengarahkan ke dokumen lain. 

1. klik pada kolom pertama pada tabel yang berisi 3 kolom  

2. ketikkan  kata Cuisine.  

3. tekan spasi dan ketikkan kata Chef Ipsum.  

4. ulangi langkah tersebut untuk kata-kata berikut: Articles, Special Events, 

Location, Menu, Contact Us.  

Jangan menekan Enter pada saat mengetik kata-kata tersebut. Gunakan spasi 

untuk memisahkan antar kata, teks akan ditempatkan secara otomatis sesuai 

dengan lebar tabel. 

5. Klik tag <td> di bagian kiri bawah   

 
Gambar 25. Tag selector 

6. Pada Property inspector (Window > Properties), pilih Top dari pop-up menu 

Vert.  

7. Simpan.  

 

Membuat link 

Sebuah link adalah referensi pada sebuah halaman yang merujuk pada dokumen lain. 

Langkah-langkah membuat link adalah sebagai berikut: 

1. Pilih kata Cuisine  

2. Pada Property inspector (Window > Properties), klik ikon folder di dekat kotak 

Link.  

 
Gambar 26. Klik ikon folder untuk menentukan file  

3. Pada kotak Select File, cari file menu.html, klik OK  
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4. Hasilnya, kata Cuisine akan bergaris bawah dan berwarna biru yang 

mengindikasikan teks tersebut adalah link. 

5. Ulangi langkah-langkah  1- 3 untuk kata-kata Chef Ipsum, Articles, Special 

Events, Location, Menu, dan Contact Us.  

6. Simpan kembali file index.html.  

 

Mem-preview halaman pada web browser 

1. Pastikan file index.html sudah terbuka  

2. Tekan tombol F12 pada keyboard 

Maka akan ditampilkan halaman web pada browser Mozilla seperti berikut. 

 
 

Gambar 27. Hasil preview  

 

***************** 


