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Pendahuluan 

Bahasa pemrograman Delphi dapat digunakan untuk berbagai keperluan baik 

untuk perhitungan matematis, aplikasi perkantoran, aplikasi multimedia, pembuatan 

aplikasi pengolah, aplikasi kontrol industri sampai kepada aplikasi database.  

 

Borland Database Engine (BDE) 

Borland Database Engine adalah suatu engine yang berfungsi untuk mengolah 

database. Borland Database Engine sering dikenal dengan sebutan BDE. BDE ini 

merupakan standar bagi produk keluaran Borland baik untuk Delphi, Borland C 

maupun bahasa program lainnya.  

Dalam program Delphi secara otomatis sudah terdapat BDE yang terintalasi 

pada waktu kita melakukan instalasi Delphi. BDE diperuntukkan khusus untuk 

menangani dan mengolah aplikasi basis data. Di dalam BDE terdapat driver yang 

berfungsi untuk menghubungkan antara aplikasi yang dibangun menggunakan Delphi 

dengan program pengelola database (DBMS) seperti paradox, dBase, Interbase. 

Demikian juga untuk sistem database raksasa yang berskala besar seperti Oracle, 

SyBase, Interbase, MS Acces dan Informix juga telah disediakan drivernya oleh BDE 

sebagai add on atau tambahan kemampuan Delphi. 

 

Database Desktop 

 Untuk membangun suatu databse, Delphi telah menyediakan fasilitas 

Database Desktop. Program  Database Desktop merupakan program bantu yang 

telah disediakan oleh Borland Delphi untuk membangun aplikasi database. Program 

database dektop  ini dapat dijalankan di luar program Delphi dengan memilih tombol 

Start > Program > Borland Delphi > Database Desktop 

Pengembangan SIM Sederhana dengan Delphi 
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Maka akan muncul Tampilan Utama program Sebagai berikut :  

 

Gambar 1. Aktivasi Database Desktop 

 

Fasilitas Database Desktop 

Dalam program Database Desktop telah disediakan 8 menu utama yang didalamnya 

mengandung banyak sub menu. Menu utama dalam Database Desktop yaitu File, 

Edit,  View, table, Record, Tools, Window dan Help. Database desktop ini 

merupakan versi 7.0 yang mendukung format paradox 3.5, paradox 4, paradox 5, 

paradox 7, dBase III+, dBase IV, dBase For Windows, Visual dBase dan interbase.  
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Menentukan Direktori Kerja 

Letak penyimpanan file database sangat mempengaruhi unjuk kerja program yang 

akan dibangun. Selain itu letak direktori kerja ini juga terkait dengan kemudahan yang 

akan didapatkan dalam bekerja. 

Untuk melakukan setting direktori kerja caranya adalah sbb :  

 Pilih menu File > Work Directory 

 

 Pilih browse lalu tentukan letak direktori kerja yang diinginkan sebagai contoh 

tuliskan D:\Modul database\ 

 Pilih tombol OK 

 

Mengatur Alias 

Komputer sekarang ini mempunyai Hardisk yang sangat besar bisa mencapai 

120 GB dengan partisi yang banyak dan data yang banyak pula. Hal ini tentu 

membuat kesulitan dalam pencarian letak data yang diinginkan. Dengan adanya alias 

ini akan sangat membantu memudahkan penempatan letak direktori yang akan 

digunakan untuk aplikasi database. 

 Disamping direktori seperti penjelasan di atas, alias juga dapat dijadikan 

sebagai default penentuan kerja kita. Alias sebenarnya menunjuk ke alamat di H-Disk 

kita pada direktori yang telah ditentukan. Cara seperti gambar 2 yaitu tentukan 

aliasnya. 

 Untuk membuat alias baru caranya dari menu Tools >Alias Manager maka 

akan muncul 
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 Pilih Tombol New lalu isikan namanya pada kotak edit Database Alias, misal 

Dataku. Tentukan juga path atau directori tempat alias tersebut.  

 Klik Tombol OK 

 

Latihan 1 Membuat Tabel Dengan database desktop 

Database tersusun atas tabel-tabel. Untuk membuat tabel dengan database 

desktop tidaklah sulit.  Caranya adalah sbb : 

 Pilih menu File > New > Table maka akan muncul kotak dialog sbb : 

 

 Aktifkan daftar pilihan Table type dan pilihlah salah satunya misalnya 

Paradox 7. lalu klik OK. Database desktop akan menampilkan menu sbb : 

 

 Tampilan tersebut telah menyediakan area yang tersorot yang siap untuk diisi 

dengan teks sebagai nama fields seperti pada MS Acces.  

 Isikan nama field pada kolom Field Name 

 Tentukan tipe data pada menu Type 

 Tentukan ukuran data 

 Tentukan key jika field tersebut dijadikan sebagai primary key 

 Isilah field sesuai dengan kebutuhan dan hasil rancangan. 

Sebagai contoh data mahasiswa dengan 3 field sbb : 

Field Type Size Key 

NPM A (Alta/Text) 5 Ya 

Nama A (Alta/Text) 30  

Foto G (Graphic)   
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Tipe data yang terdapat pada pada Paradox 7 adalah sebagai berikut :  

 

 

 

Alpha untuk tipe data berupa text (string) 

Number untuk tipe data berupa angka 

$(Money) Untuk mata uang 

Short Untuk data bilangan bulat 

Long Integer untuk data bilangan bulat  

# BCD 

Date untuk tipe data tanggal 

@ (timestamp) : Data Jam dan Tanggal 

Memo untuk tipe data teks berukuran besar 

Formatted memo untuk memo terformat 

Graphic untuk gambar 

OLE untuk Data dari aplikasi lain 

Logical untuk tipe data berbentuk logika (yes/no) 

+ auto increment (angka otomatis naik 1) 

Binary untuk data berbentuk biner 

Bytes untuk data byte 

 

 Untuk menentukan index sebagai relasi dengan tabel yang mempunyai 

hubungan dapat dilakukan dengan memilih Secondary Indexes pada Table 

Properties lalu pilih tombol Defines maka akan muncul tampilan sbb : 

 

 

 Pilih Field yang akan dijadikan index dengan menekan Tombol Panah 
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 Klik Tombol OK 

 

 Berinama Index dengan nama yang berbeda dengan Nama Field contoh 

Namanya Mahasiswa 

 Tekan tombol OK maka akan muncul seperti pada gambar berikut : 

 

 Coba perhatikan Perbedaanya dengan Sebelumnya... 

 Pilih dan Tekan Tombol Save As lalu berinama tabel_Mahasiswa dan tentukan 

tempat penyimpanan File tabel tersebut akan disimpan. 

 Anda juga dapat menyimpan melalui Alias yang telah anda buat yaitu di Alias 

Modul seperti terlihat pada Gambar di bawah ini.  

 

 Pilih Tombol Save sudah selesai Tabel Mahasiswa dibuat 

 

Mengisikan tabel 

Untuk mengisi tabel langkahnya sbb : 

Pilih menu Table > Edit Data maka kita sudah dapat mengisi data langsung pada sheet 

seperti pada gambar 
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Untuk Field Foto karena berupa grafik tidak bisa diisi dari Database Desktop biarkan 

tetap kosong nanti bisa diisi dari program Delphi.  

 

Mengatur Tabel 

Setelah tabel terbentuk kita dapat melakukan editing untuk disesuaikan dengan 

kebutuhan. Kadang di masa yang akan datang ada perubahan jenis datanya atau 

bahkan ada tambahan field untuk itu tabel yang sudah terbentuk dapat diedit.  

Langkah melakukan editing tabel pada database desktop 

1. Buka tabel dari menu File > Open > Table. 

2. Dari kotak dialog pilih letak forder tempat tabel disimpan atau dari alias 

dimana tabel tersebut diletakkan 

3. setelah tabel terbuka pilihlah Menu Table > Edit Data 

4. Klik data yang akan diedit lalu isilah dengan data yang sesuai dengan 

perubahan data yang diinginkan 

 

Langkah Mengubah susunan Tabel 

1. Pilih Menu Table > Restructure lalu akan muncul tampilan sbb :  

 

2. Klik field yang akan diubah 

3. Isikan dengan pengganti yang diiginkan 

4. Pilih tipe data yang sesuai 
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Memulai Program database Dengan Delphi 

Delphi telah menyediakan komponen database yang akan memudahkan kita 

dalam merancang dan membangun aplikasi database. Komponen-komponen database 

dikelompokkan dalam Component Pallete Data Acces Data Control dan BDE Serta 

ADO. 

 Data Acces dan BDE banyak  berperan pada penentuan sumber data seperti 

tabel, SQL, query maupun koneksivitasnya. Contoh komponen ini yaitu Table 

dan Datasource. 

 Data Control lebih menekankan pada pengaturan data yang terpasang pada 

aplikasi sepeti DBLabel, DBNavigator, DBGrid, DBImage, DBMemo, 

DBEdit, DBCombobox dan lain sebagainya. 

 ADO digunakan untuk komunikasi Program dengan Database MS Acces 

sehingga data yang dibuat dengan Acces akan dapat diintegrasikan dengan 

Delphi 

 Contoh implementasi program database dengan Delphi (Desain Form) 

 

Jika ingin menggunakan Database MS Acces maka digunakan komponen 

ADOTable sebagai pengganti Table 

 

Daftar Komponen Yang Digunakan 

 Table   Ada di Pallete BDE  

 DataSource  Ada di Pallete Data Acces 

 DBNavigator  Ada di Pallete Data Control 



Kuliah Pemprograman Komputer 

@2005 Muhamad Ali, M.T 

9 

 DBGrid  Ada di Pallete Data Control 

 DBEdit  Ada di Pallete Data Control 

 ADOTable  Ada di Pallete ADO 

 

Lihat Component Pallet pada gambar di atas 

 

Untuk Tabel dapat digunakan Table yang ada di BDE jika ingin menggunakan 

database dari driver BDE seperti Paradox, dBase dll. Atau jika ingin menggunakan 

Data dari MS Acces dapat digunakan komponen ADO yaitu ADOTable. 

 

Perancangan Aplikasi Database 

Setelah mempelajari komponen-komponen yang telah disediakan oleh Delphi 

untuk aplikasi database maka kini saatnya kita mencoba untuk merancang aplikasi 

database sederhana. Dengan Delphi kita dapat membuat suatu program aplikasi 

database yang menarik dan handal dengan integrasi DBMS seperti paradox, Interbase, 

SyBase, Oracle bahkan MS Acces. 

Berikut ini contoh desain program database yang pernah kita buat yaitu database 

pemasaran yang terdiri dari 4 tabel yaitu Mahasiswa, Dosen, Kuliah dan Nilai.  

 

Mengeksport Database Acces Ke Paradox 

Anda dapat menyusun program database baru dalam format Paradox atau tetap 

menggunakan Acces. Anda dapat juga mengekspor database Acces ke dalam Paradox 

dari MS Acces caranya sbb : 

 Dari menu MS Acces klik kanan tabel yang akan diubah ke Paradox 

 

 Pilih Export seperti pada gambar di atas.  
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 Beri Nama lalu pilih save As Type menjadi Paradox 7-8 (*.db) 

 Tekan tombol Export 

 

Latihan 2 Membuat Aplikasi Database Dengan Delphi 

 Buka aplikasi baru dengan cara File > New > Application, maka akan muncul 

form baru.  

 Desainlah tampilan form dengan menempatkan komponen di atas dan atur 

properti-nya sehingga nampak seperti pada gambar di bawah. 

 

 Komponen yang digunakan adalah DataSource, Table, DBGrid, 

DBNavigator dan DBText. 

 Desain form dengan meletakkan komponen-komponen database seperti pada 

gambar di atas caranya seperti pada latihan 1 modul 5 

 Aturlah properti masing-masing komponen pada object inspector sebagai 

berikut : 

Komponen Properties Nilai Properti 

Table Name Table1 

 Database Name Modul 

 Table Name Mahasiswa 

 Active True 

DataSource Name DataSource1 

 Dataset Table1 
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DBGrid Name DBGrid1 

 Data Source DataSource1 

DBNavigator Name DBNavigator1 

 Data Source DataSource1 

DBText Name DBText1 

 Auto Size True 

 Field Name Nama 

 

 Setelah database anda susun seperti pada instruksi di atas, jika sudah benar 

maka hasilnya akan nampak seperti pada gambar berikut : 

 

 Jika tidak berarti masih ada kesalahan dan harus dicek dimana letak 

kesalahannya. 

 Jalankan program dengan menekan tombol F9 atau pilih menu Run > Run 

maka akan muncul sebagai tampilan sebagai berikut : 

 

 DBNavigator berfungsi untuk memanipulasi database yang ada, yaitu menuju 

record selanjutnya, data terakhir, menambah data, menghapus data, mengedit 

data dan lain sebagainya. 

 Latihan sudah selesai 

 

Database Form Expert 

Kita telah membuat sebuah aplikasi database sederhana dengan Delphi dan 

sudah menikmati mudahnya membuat program aplikasi dengan mudah dan cepat. 

Delphi mempunyai fasilitas yang akan memudahkan kita dalam membuat dan 

mendesain form database dengan Database Form Expert. Cara pembuatan form 
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dengan Database Form Expert mirip dengan Wizard yang disediakan pada program 

MS Acces yang telah kita pelajari pada mingu-minggu kemarin. Dengan menu ini kita 

tinggal memilih menu yang diinginkan dan Delphi yang akan mengerjakan 

sepenuhnya. 

 

Latihan 3 Membuat Form Database Dengan Database Form Expert  

1. Dari menu File pilih New > Application 

2. Dari menu Database pilih Form Expert maka akan muncul tampilan seperti 

gambar di bawah 

 

3. Pada kotak dialog ini terdapat 2 pilihan yaitu Form Option dan dataset option 

4. Dalam form option disediakan 2 pilihan berupa create simple form dan create 

master/detail form. 

5. Dataset option menyediakan komponen yang akan dipakai untuk pengaksesan 

data, komponen table atau query 

6. Pilih create a simple form dan create a form using table object lalu tekan 

tombol Next maka akan muncul dialog sbb: 

 

7. Pilihlah tabel yang akan dijadikan form dengan memilih Alias = Modul atau 

letak directori di D:\Modul Database lalu tekan Next 
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8.  Pilih field yang akan dimasukkan dalam Form dengan menekan tombol > atau 

tombol >> untuk memasukkan semua field pada tabel 

 

9. Pilihlah Tampilan mau Horizontal, Vertikal atau InGrid lalu tekan Next 

10. pilih Generate a main form jika form ini akan dijadikan form jika tidak maka 

tidak perlu dicek tanda tersebut. Tekan tombol Finish 

11. Setelah selesai maka akan muncul form baru sebagai berikut :  

 

12. Kita dapat melakukan perubahan terhadap Tampilan Form sesuai dengan 

keinginan dengan menambahkan tombol, text, image, panel atau komponen-

komponen lainnya yang sesuai. 
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Contoh lain pembuatan form database dengan Wizard 

 

Latihan 4 Membuat Aplikasi Database Bergambar Dengan ADO 

 

 Buat Aplikasi Baru dari Menu File > New > Application 

 Desainlah Form seperti pada tampilan di atas yang berisi 7 Komponen sebagai 

berikut : 

Komponen Properties Nilai Properti 

Form Name Form1 

 Caption Database Bergambar 

ADOConnection Name ADOConnection1 

 Connection String ... 

ADOTable Name ADOTable1 

 Table Name Mahasiswa 

 Active True 

DataSource Name DataSource1 

 DataSet ADOTable1 

DBEdit Name DBEdit1 

 Datasource DataSource1 

 Data Field Nama 

DBImage Name DBImage 

 Datasource DataSource1 

 Data Field Foto 

DBNavigator Name DBNavigator1 

 Datasource DataSource1 

Button Name Button1 

 Caption Data Baru 

Button Name Button2 

 Caption Hapus 
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 Sebelumnya anda harus membuat Database Dengan MS Acces dengan nama 

latihan4 dan buat tabel dengan nama mahasiswa pada database tersebut lalu 

Tekan OK 

 Pilih komponen ADO lakukan pengaturan properties dengan memilih Table 

Name menjadi Mahasiswa dan Active menjadi true 

 Pilih komponen ADOTable lalu atur properties di Object Inspector Pada 

ConnectionString sbb : 

 

 Pilih Tombol ... pada Connection String pada gambar di atas sehingga muncul 

tampilan sbb : 

 

 Pilih Use Connection String Lalu Pilih Tombol Build 
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 Pilih Microsoft Jet 4.0 OLE DB Provider lalu pilih Next sehingga muncul 

tampilan gambar di atas 

 Pilih Nama Database dengan menekan tombol ... dipojok kanan lalu pilih 

database-nya. 

 Tekan Tombol Test Connection untuk memastikan database sudah benar 

  

 Setelah dipilih database connection maka sekarang tinggal memilih tabel yang 

akan digunakan. Lihat gambar di atas. Active menjadi True 

 Setelah semuanya diatur melalui properti dengan benar maka akan tampak 

pada gambar seperti di di bawah ini. Gambar dan Nama akan muncul jika 

database sudah diisi dengan data jika belum maka tidak akan muncul 

 

 Isilah Kode Program dengan klik dobel pada Tombol Data Baru sbb : 

Procedure TForm1.Button1Click(Sender: TObject); 

begin 

      form2.show; 

      ADOtable1.Append; 

end; 

 Isilah Kode Program dengan klik dobel pada Tombol Hapus Data sbb : 

Procedure TForm1.Button2Click(Sender: TObject); 

begin 

     if messagedlg('Hapus data       ?', mtConfirmation,  

      [mbYes,mbNo],0)=mryes then ADOtable1.delete;  

end; 

  
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 Tambahkan Form baru untuk input data sbb : 

 

Komponen Properties Nilai Properti 

Form Name Form2 

 Caption Input Data Mahasiswa 

DBEdit Name DBEdit1 

 Datasource DataSource1 

 Data Field No 

DBEdit Name DBEdit2 

 Datasource Form1.DataSource1 

 Data Field Nama 

DBImage Name DBImage 

 Datasource Form1.DataSource1 

 Data Field Foto 

OpenPictureDialog Name OpenPictureDialog1 

Button Name Button1 

 Caption Insert 

Button Name OK 

 Caption Hapus 

 

 Isikan Program dengan menekan dobel klik pada Button (Insert) dengan 

program sbb : 

Procedure TForm2.Button1Click(Sender: TObject); 

begin 

     if openpicturedialog1.execute then 

     begin 

          dbimage1.Picture.LoadFromFile(openpicturedialog1.FileName); 

     end; 

end; 

  

 Dobel Klik Button2 (OK) Dengan kode program sbb :  

Procedure TForm2.Button2Click(Sender: TObject); 

begin 

      form1.ADOtable1.post; 

      close; 

end; 

 Sudah Selesai tinggal program dijalankan dengan menekan tombol F9 maka 

tampilannya sbb : 
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 Tombol Navigator < dan >  digunakan untuk menggeser data ke bawah dan ke 

atas. 

 Jika Tombol Data Baru ditekan maka muncul tampilan seperti pada gambar di 

atas. 

 Jika pada Form2 ditekan tombol Insert maka akan muncul tampilan untuk 

memilih gambar sebagai berikut : 

  

 

Membuat Relasi Antara 2 Tabel 

Contoh yang telah dijelaskan di atas masih merupakan database yang terdiri 

dari 1 tabel. Padahal dalam kenyataan terkdang terdapat banyak tabel seperti pada 

kasus database jurusan Pemasaran yang telah dibahas dengan MS Acces. Untuk itu 

perlu dibahas juga tentang database relasi antara 2 tabel dulu agar pemahaman 

menjadi lebih baik. 

Dalam database pemasaran kemarin ada 4 tabel yang saling berkaitan yaitu Tabel 

Mahasiswa, Dosen, Kuliah dan Nilai. 

 

Latihan 5 Buat Program Relasi Tabel 

Sebagai latihan ambil salah 2 dari 4 tabel di atas untuk digunakan sebagai relasi tabel 

yang akan dijelaskan dalam program. Misalnya tabel Mahasiswa dan tabel Nilai. 

 Desainlah tampilan form sepeti pada gambar berikut ini 
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 Komponen yang digunakan yaitu 1 Form, 1 Page Control, 2 TabSheet, 2 

Table, 2 DataSource, 2 DBGrid dan 3 Button  

 Desainlah seperti pada gambar masing-masing komponen 

 Properti pada masing-masing komponen adalah sebagai berikut : 

Komponen Properties Nilai Properti 

Table Name Table1 

 Database Name Modul 

 Table Name Mahasiswa 

 Active True 

Table Name Table2 

 Table Name Mahasiswa 

 Active True 

 Database Name Modul 

DataSource Name DataSource1 

 Dataset Table1 

DataSource Name DataSource2 

 Dataset Table2 

DBGrid Name DBGrid1 

 Data Source DataSource1 

DBGrid Name DBGrid2 

 Data Source DataSource2 

DBNavigator Name DBNavigator1 

 Data Source DataSource1 

DBNavigator Name DBNavigator2 

 Data Source DataSource2 

Page Control Name PageControl1 

 Field Name Nama 

 

 Dari Form kosong masukkan komponen Page Control yang terletak pada 

Component Pallete Win32 klik dobel komponen Page Control 
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 Pilih Page Control seperti pada gambar di atas lalu klik kanan sehingga 

muncul Pop Up Menu 

 

 Pilih New Page lakukan sebanyak 2 kali sehingga muncul tampilan sbb: 

  

 Ubah properti TabSheet1 dan TabSheet 2 pada Object Inspector seperti 

pada gambar di atas Menjadi Mahasiswa Dan Nilai 

 Tambahkan komponen DBGrid pada Tabsheet1 dan TabSheet2,  

 Tambahkan Komponen Table 2 buah 

 Tambahkan Komponen DataSource 2 buah 

 

 Setting Parameter Tabel, DataSource, DBGrid melalui Object Inspector seperti 

pada keterangan tabel di atas 

 Sehingga muncul sebagai berikut : 
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 Tambahkan 3 Button pada masing-masing Tabsheet sehingga ada 6 button 

dengan tampilan seperti pada gambar. 

Button1 = Databaru Button2 = Ubah Data Button3 = Hapus Data  (Tabsheet1) 

Button4 = Databaru Button5 = Ubah Data Button6 = Hapus Data (Tabsheet2) 

 

Latihan 6 Buat Form Input Data Mahasiswa (Lanjutan Latihan 5) 

Tambahkan form untuk Menambah dan Mengedit Data Mahasiswa sbb : 

 

Komponen yang Digunakan adalah sbb : 

Komponen Properties Nilai Properti 

Form Name Form2 

 Caption Input Data Mahasiswa 

Label Caption Input Data Mahasiswa 

 Font - Size 14 

 Align Center Window 

DBText1 Datasource Form1.DataSource1 

 Data Field NPM 

DBText2 Datasource Form1.DataSource1 

 Data Field Nama 

DBText3 Datasource Form1.DataSource1 

 Data Field Alamat 

DBText4 Datasource Form1.DataSource1 

 Data Field Tgl_Lahir 

DBText5 Datasource Form1.DataSource1 

 Data Field Nama_Orang_Tua 

DBEit1 Datasource Form1.DataSource1 

 Data Field NPM 

DBEit2 Datasource Form1.DataSource1 

 Data Field Nama 

DBEdit3 Datasource Form1.DataSource1 

 Data Field Alamat 

DBEdit4 Datasource Form1.DataSource1 

 Data Field Tgl_Lahir 

DBEdit5 Datasource Form1.DataSource1 
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 Data Field Nama_Orang_Tua 

Button1 Caption OK 

Button2 Caption Cancel 

 

 Isilah Kode Program dengan klik dobel pada Tombol Data Baru (Button1) sbb 

Procedure Tform1.BitBtn1Click(Sender: TObject); 

begin 

          form2show; 

          table1.append; 

end; 

 Isilah Kode Program dengan klik dobel pada Tombol Edit Data sbb : 

Procedure Tform1.BitBtn2Click(Sender: TObject); 

begin 

          form2.show; 

          table1.edit; 

end; 

 Isilah Kode Program dengan klik dobel pada Tombol Data Baru sbb :  

procedure Tform1.BitBtn6Click(Sender: TObject); 

begin 

      if messagedlg('Hapus data ?', 

mtConfirmation,[mbYes,mbNo],0)=mryes then  

table1.delete; 

end; 

 Buatlah Form baru untuk menambah dan mengedit data Nilai seperti pada 

pembuatan Form Input Data Mahasiswa dengan Desain Tampilan sbb : 

 

 Gunakan Komponen DBEdit sebanyak 3 buah dan DBText sebanyak 3 buah 

serta 2 buah tombol Button (OK Dan Cancel). 

 Tempatkan dan atur posisinya seperti pada gambar di atas. 

 

 

 Klik Dobel Tombol Button1 (OK) dan isilah kode program sbb : 

Procedure Tform3.BitBtn1Click(Sender: TObject); 

begin 

          form1.table1.post; 
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          close; 

end; 

 

Procedure Tform3.BitBtn2Click(Sender: TObject); 

begin 

       form1.Table1.cancel; 

       close; 

end; 

 

 Setelah selesai Program Dijalankan dengan Menekan Tombol F9 maka 

 Hasil tampilan program adalah sebagai berikut :  

 

 Jika Diklik Tombol Data Baru Pada Tabsheet Mahasiswa Maka Akan 

muncul form seperti pada gambar di bawah ini.  Begitu pula jika di tekan 

tombol Edit Data. 

  

 Jika Diklik Tombol Data Baru Pada Tabsheet Nilai Maka Akan muncul 

form seperti pada gambar di bawah ini. Begitu pula jika di tekan tombol 

Edit Data. 
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 Jika di pilih tombol Hapus data maka akan muncul tampilan sbb :  

 

 Jika dipilih Yes maka data yang tersorot (Nilai dari Mahasiswa NPM=101, 

Kode Kuliah 01 dengan Nilai = 6 Akan terhapus. 


