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Chapter 1

Pendahuluan

1.1 Welcome to LyX!

Untuk membuat suatu dokumen, baik itu surat, artikel, maupun jurnal
pada umumnya kita masih menggunakan aplikasi dokumen semacam MS
Office Word, LibreOffice Writer, maupun aplikasi pengolah dokumen yang
bergenre WYSIWYG yang lain. Sesungguhnya penggunaan pengolah doku-
men semacam MS Office Word banyak menghabiskan waktu untuk format-
ting dan segala tetek bengek urusan yang sebenarnya tidak berkaitan lang-
sung dengan produksi dokumen. Ditambah lagi dengan masalah kompatibil-
itas suatu format dokumen antara aplikasi pengolah kata yang masih sangat
buruk. Sebagai contoh, ketika kita ingin mengedit suatu dokumen daru MS
Word 2007 ke MS Word 2003, terkadang formattingnya-nya pun tidak co-
cok, terlebih lagi jika operating system yang digunakan berbeda, misalnya
dari Linux ke Windows. Alhasil sering kali pekerjaan tertunda hanya karena
harus menformat ulan dokumen,

Sebenarnya ada pilihan lain untuk menyiapkan dokumen dan ini meru-
pakan solusi lama karena sudah ada sejak era 70an. Pengolah dokumen terse-
but adalah TEX, yang berkembang menjadi beberapa varian yakni Latex,
Context, dll. Pada umumnya pengolah dokumen tersebut berbasis source,
alias jika ingin menyiapkan suatu dokumen, kita harus menulis dokumen
tersebut bersama dengan kode yang mengatur formatting dokumennya. Hal
ini terlihat merepotkan, walaupun selanjutnya format tersebut dapat digu-
nakan berulang — ulang tanpa harus mengaturnya kembali untuk dokumen
serupa yang lain.
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Nah, untuk memudahkan membuat dokumen dengan memanfaatkan TEX,
diperkenalkan IyX yang lebih berbasis GUI (Graphical User Interface), di-
mana kita tidak perlu memahami bagaimana membuat dokumen dengan
TEX tersebut, yang penting semua setting TEX dibantu oleh LyX, dan kita
cukup berkonsentrasi bagaimana menggunakan /menulisnya saja. Permasala-
hannya adalah bagaimana membiasakan diri dengan IxyX.

1.2 Apakah IyX itu?

Ly merupakan suatu sistem persiapan dokumen. [yX merupakan suatu alat
untuk menghasilkan suatu manuskrip, buku, surat dan proposal bahkan puisi
yang dalam format yang cantik. Tidak seperti pengolah kata pada umumnya,
dalam arti bahwa IyX menggunakan paradigma bahasa markup sebagai gaya
pengeditan intinya. Dengan kata lain, ketika Anda mengetik suatu header
pada suatu bagian, maka Anda akan menAndainya sebagai "Section", bukan
sebagai "Bold, 17 pt type, left justified, bmm space below". IyX akan mengu-
rus typesetting untuk Anda, sehingga Anda hanya cukup berurusan dengan
konsep dan isi dokumen, bukan dengan mekaniknya.



Nur Insani - nurinsani@uny.ac.id

Chapter 2

Memulai dengan LyX

2.1 Instalasi ILyX di Windows

Lyx membutuhkan pustaka MikTex untuk dapat digunakan karena LyX
hanyalah program antar muka sedangkan back end-nya ditangani oleh Mik-
Tex. Apakah MikTex itu? MikTex adalah port atau varian dari LaTex yang
bekerja di MS Windows. Dalam CD pelatihan ini, Anda cukup mengklik
file [yX-2.0.3-2-Alt-Bundle.exe, lalu ikuti perintahnya hingga Anda menda-
patkan jendela awal LyX.

Catatan: Semua program tersebut dapat didownload secara gratis pada
http://wiki.lyx.org/Windows/Windows atau http://wiki.lyx.org/Windows/
WindowsSetup.

2.2 Basic File Operations

Dibawah menu File dan didalam toolbar stAndar terdapat operasi-operasi
dasar seperti pada setiap pengolah data pada umumnya, serta beberapa op-
erasi tambahan, yaitu:

e New ,ﬁ

¢ New from_Template

« Open 5’

¢ Close
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e Save E

o Save As

o Revert to saved
e Version Control
e Import

e Export

e Print Cg

o Exit

Fungsi dari tombol tersebut hampir sama dengan yang ada di pengolah data
lainnya, hanya ada sedikit perbedaan. Perintah FilerNew from_Template
tidak hanya meminta Anda untuk menamai file baru, tetapi juga akan menanyakan
template yang akan digunakan pada file beru tersebut. Memilih suatu tem-
plate secara otomatis akan mengatur tata letak fitur-fitur tertentu pada
dokumen dan jika Anda ingin merubah suatu fitur tertentu, maka Anda
harus merubahnya secara manual. Anda dapat menggunakan suatu kelas
atau template tertentu, yang telah tersedia didalam IyX (lihat bagian 3.1).

Tombol Revert to saved dan Version Control bermanfaat untuk pengguna
yang bekerja pada dokumen yang sama di saat yang sama pula. Tombol
Revert to saved akan memuat ulang dokumen dari disk. Anda dapat meng-
gunakan tombol tersebut jika Anda ingin menginginkan dokumen Anda kem-
bali ke format pada penyimpanan terakhir. Dengan tombol Version Control,
Anda dapat mendaftar perubahan yang Anda lakukan pada suatu dokumen
sehingga orang lain dapat mengidentifikasi perubahan tersebut.

2.3 Fitur Dasar Editing

Seperti pada pengolah data modern lainnya, [y X dapat melakukan operasi
cut dan paster pada suatu kalimat, dapat memindah karakter, kata atau
halaman suatu teks, dan dapat menghapus seluruh kata maupun karakter
tunggal.

Seperti yang mungkin Anda harapkan, menu Edit dan toolbar stAndar
menyediakan perintah cut dan paste, dengan berbagai fitur edting laiinya.
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Beberapa dari mereka merupakan fitur spesial dari IyX. Fitur-fitur dasar
tersebut diantaranya:

e Cut }{
+ Copy

u

o Paste F%

o Paste Recent

o Paste Special

i.
« Find & Replace %

Anda dapat menyalin teks antara IyX dan program lainnya dengan cara
menggunakan fitur cut dan paste. Submenu Paste Recent menyediakan suatu
daftar beberapa string terakhir yang telah Anda salin.

Menu Editr> Paste Specialt>Plain Text, Join Lines akan memasukkan teks
dalam clipboard sehingga semua teks dimasukkan sebagai satu paragraf.
Sebuah paragraf baru dimulai ketika ada baris kosong dalam file. Tanpa
Join Lines, teks dimasukkan ke dalam beberapa paragraf, di mana pada jeda
baris dari teks tersebut akan menjadi suatu paragraf baru.

Anda dapat memilih Edit>Find & Replace (tombol toolbar -G%) untuk
mencari suatu kata. Pada kotak dialog, Anda dapat mencari dengan tombol
Find Next dan lalu menggunakan tombol Replace untuk mengganti kata yang
Anda cari. Jika Anda suka, Anda dapat meneetukan apakah akan melakukan
pencarian dengan kasus-sensitif (hurh kapital/kecil), atau hanya mencari
kata-kata lengkap, Anda juga dapat mencari mundur pada dokumen terse-
but.

Character Formatting Anda dapat merubah bentuk teks seperti dengan
menggunakan menu Edit> Text Style (tombol toolbar ab)

Toolbar Tombol-tombol toolbar (dibawah tombol-tombol menu) memungkinkan

Anda untuk melakukan beberapa fungsi yang populer seperti Paste dan
Print.

Tentu saja, pada saat ini ANda belum banyak menulis sehingga belum banyak
menggunakan fungsi-fungsi toolbar tersebut. Seiring dengan Anda menulis,
cobalah menggunakan fungsi-fungsi toolbar tersebut untuk menghemat waktu.
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2.4 Undo dan Redo

Jika Anda membuat suatu kesalahan, Anda dapat dengan mudah mengem-
balikannya ssperti semula. IyX mempunyai kapasitas besar untuk buffer

undo/redo. Pilih Edit>Undo atau tombol [@' untuk membatalkan (undo)
kesalahan. Jika Anda secara tidak sengaja membatalkan kesalahan terlalu

banyak, gunakanlah Edit> Redo atau tombol @ untnuk membatalkan yang
dibatalkan. Mekanisme pembatalan ini dibatasi hingga 100 langkah untuk
meminimalkan memori overhad. Undo dan Redo bekerja pada hampir semua
dokumen di LyX, tetapi mereka tidak membatalkan atau mengulang teks
karakter per karakter, tetapi langsung dalam bok teks.

2.5 Mengetik, Melihat Hasil, dan Mengek-
spor

o Buka suatu file baru dengan cara pilih Filer>New
o Ketik suatu kalimat seperti:: Ini dokumen IyX pertama saya!
o Simpan dokumen Anda dengan cara pilih FilerSave As.

o Jalankan I¥TEX untuk menghasilkan suatu file DVI, dengan cara memilih

View>DVI atau cukup dengan tombol . LyX akan membuka su-
atu program DVI-viewer yang akan menampilkan dokumen Anda se-
bagaimana akan terlihat ketika dokumen tersebut dicetak. !

o Ekspor the dokumen yang sudah siap dengan cara pilih menu Filer
Export ke format yang Anda inginkan.

Selamat! Anda telah berhasil menulis dokumen dalam LyX! You have writ-
ten your first LyX document.

! Anda dapat menghemat waktu dengan cara membiarkan DVI-viewer terbuka di back-
ground. Kemudian, Anda dapat memilih menu View > Update>DVI atau cukup menekan
tombol &2 dan klik pada jendela DVI-viewer tadi (atau me-unminimize jendelanya) setelah
ETEX selesai mengupdate.
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2.5.1 WYSIWYM: Spasi di LyX

Salah satu hal yang paling sulit bagi pengguna baru untuk membiasakan diri
adalah cara IyX menangani spasi. Sebanyak Anda menekan Return, Anda
hanya akan mendapatkan satu baris kosong. Sebanyak Anda menekan Space,
Anda hanya akan mendapatkan satu ruang. Pada baris kosong, IxX tidak
akan membiarkan Anda mengetik bahkan untuk satu space (ruang). Tombol
Tab tidak akan menggerakkan Anda maju satu tab, bahkan tidak ada fungsi
tab! Tidak ada aturan pada bagian atas halaman untuk memungkinkan
Anda mengatur tab atau margin.

Pengolah kata pada umumnya didasarkan pada prinsip WYSIWYG (“What

You See Is What You Get”): "Apa yang Anda Lihat adalah Apa yang
Anda Dapatkan." LyX, di sisi lain, didasarkan pada prinsip bahwa apa yang
Anda ketik adalah apa yang Anda maksud (“What You See Is What You
Mean”), dan IxyX akan mengurus typesetting untuk Anda, sedemikian se-
hingga output terakhir akan terlihat rapi dan indah. Dengan menggunakan
LyX, Anda akan menghabiskan lebih banyak waktu untuk berkonsentrasi
pada isi dokumen Anda, dan hanya sedikit waktu untuk mengkhawatirkan
formatnya. Intinya adalah Anda dapat mengetik seluruh dokumen dan hanya
menfokuskan pada isi dokumen Anda. Dengan pengolah kata stAndar lain-
nya, Anda akan terganggu dengan format dokumen selama proses menulis.

2.6 Environments

Setiap bagian dari dokumen memiliki tujuan yang berbeda, kami menye-
butnya dengan bagian lingkungan (environments). Sebagian besar dokumen
terdiri dari teks biasa. Bagian judul (bab, ayat, dll) membiarkan pembaca
tahu bahwa topik baru atau subtopik akan dibahas. Beberapa jenis dokumen
memiliki lingkungan khusus. Sebuah artikel jurnal akan memiliki abstrak
dan judul. Suatu surat idak membutuhkan keduanya, tapi mungkin akan
memiliki lingkungan yang menyediakan bagian untuk alamat penulis.
Lingkungan adalah bagian utama dari filosofi "Apa yang Anda Lihat
adalah Apa yang Anda Maksud' dari Iy X. Sebuah lingkungan tertentu
mungkin memerlukan gaya font tertentu, ukuran font, indentasi, spasi baris,
dan banyak lagi. Masalah ini diperparah, karena format yang tepat untuk
lingkungan tertentu dapat berubah: satu jurnal mungkin menggunakan hu-
ruf tebal, 18 point untuk fontnya, peletakan judul di tengah halaman (cen-
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tered type), sementara yang lain menggunakan cetak miring, 15 point un-
tuk fontnya, peletakan judul di sebelah kiri halaman; bahasa yang berbeda
mungkin memiliki stAndar yang berbeda untuk indentasi; dan format bibli-
ografi juga dapat sangat bervariasi. IyX memungkinkan Anda menghindari
untuk menghapalkan semua gaya format yang berbeda.

Kotak pilihan Environment terletak di ujung kiri toolbar dan terlihat

| Standard .. . .
seperti ini:. = . Kotak ini menunjukkan dilingkungan mana

Anda sedang menulis. Meskipun Anda sedang menulis dokumen pertama
Anda, kotak lingkungan akan menunjukkan "StAndar," yang merupakan
lingkungan stAndar untuk teks. Sekarang Anda akan menempatkan se-
jumlah lingkungan di dokumen baru Anda sehingga Anda dapat melihat
bagaimana mereka bekerja.

2.6.1 Sections and Subsections

Ketik kata Pendahuluan baris pertama dari file LyX Anda, lalu pilih Section
(subbab) dalam kotak Environment. ? Pastikan untuk menggunakan Section
dan bukan Section* yang akan dibahas di bawah ini. LyX akan menomori
subbab tersebut dengan "1" dan typesets judul bagian (judul) dalam font
yang lebih besar. Sekarang tekan Return. Catatan bahwa kotak Environ-
ment berubah dari belakang “Section” menjadi “Standard” kembali. Judul
subbab, seperti kebanyakan pada setiap lingkungan, diasumsikan berakhir
ketika Anda mengetik Return. Ketik pendahuluan pada dokumen Anda se-
bagai berikut:

Ini adalah pendahuluan untuk dokumen IyX saya yang pertama.

Hit Return lagi, dan pilih Section dari kotak Environment lagi. IxX menomorinya
dengan "2" dan menunggu Anda untuk mengetik judulnya. Ketik "Lebih lan-
jut', dan Anda akan melihat bahwa IyX akan menetapkannya lagi sebagai
suatu judul subbab.

2Anda tidak harus memilih suatu kalimat. Jika tidak ada yang dipilih, IxX akan
merubah paragraf yang Anda berada pada saat itu kedalam lingkungan yang dipilih.
Alternatif lain, Anda dapat merubah beberapa paragraf ke suatu lingkungan yang berbeda
dengan cara memilih mereka sebelum Anda memilih lingkungan yang dikehendaki.
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Coba Anda kembali ke akhir dari subbab 1 lagi (setelah "Ini dokumen
[yX pertama saya') dan tekan Return lagi, dan pilih Section dari kotak En-
vironment lagi. Sekali lagi, IyX akan menomori bagian tersebut dengan "2'
dan menunggu Anda untuk mengetikkan judulnya. Ketik "Tentang Dokumen
Ini". Subbab "Lebih lanjut', yang semula merupakan subbab 2, telah se-
cara otomatis dinomori ulang sebagai subbab 3! Dengan cara WYSIWYM
yang benar, Anda hanya perlu mengidentifikasi teks yang membentuk judul
bagian, dan Iy X akan mengurus penomoran bagian dan typesetting mereka.

Tekan Return untuk kembali ke lingkungan Standard, dan ketik kalimat
dibawah ini:

Sections dan subsections dijelaskan dibawah ini.
Deskripsi Section

Sections lebih luas daripada subsections.
Deskripsi Subsection

Subsections lebih sempit daripada sections.

Klik pada baris kedua dan pilih Subsection dari kotak Environment. IxX
menomorinya sebagai sub-subbab "2.1", dan menuliskannya dalam font yang
lebih besar dari teks biasa tetapi lebih kecil dari judul bagian. Ubah baris
keempat ke lingkungan Subsection juga. Seperti yang mungkin diharapkan,
LyX secara otomatis menomorinya sebagai sub-subbab '2.2". Jika Anda
menempatkan section lain sebelum subbab 2, subbab 2 akan dinomori ulang
sebagai subbab 3, dan sub-subbab akan dinomori ulang menjadi "3.1" dan
'3.2".

Tingkat lebih lanjut dari sectioning meliputi Subsubsection, Paragraph,
and Subparagraph. Kami akan membiarkan Anda bermain dengan sendiri
dengan bagian tersebut. Anda mungkin menyadari bahwa judul paragraph
dan subparagraph tidak bernomor secara default, dan bahwa letak subpara-
graph menjorok. Judul bab (chapter) sebenarnya tingkat tertinggi dari sec-
tioning, di atas Section, tetapi Anda hanya diperbolehkan untuk menggu-
nakannya dalam jenis tertentu (kelas teks) dari dokumen IyX (lihat Bagian
[sec: Document-Classes]).

Anda mungkin ingin memiliki bagian (sections) atau subbagian (subsec-
tions) yang tidak bernomor. Tersedia pula lingkungan untuk hal ini juga.
Jika Anda mengubah salah satu judul subbab Anda ke lingkungan Section*
(Anda mungkin harus scroll ke bawah di kotak Environment untuk mene-
mukannya), IyX akan menggunakan ukuran font yang sama untuk heading
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seperti pada regular subbab, tetapi tanpa nomor. Begitu pula dengan bagian
Subsection dan Subsubsection. Cobalah mengubah beberapa bagian atau
subbagian ke lingkungan berbintang, dan perhatikan bagaimana penomoran
pada bagian lain diperbarui.

Exercise: Perbaikilah Memperbaiki judul bagian dan subbagian ayat
dalam example_raw.lyx.

2.6.2 Lists and sublists

Iy X memiliki beberapa lingkungan yang berbeda untuk menuliskan daftar
(list). Berbagai lingkungan tersebut membebaskan Anda untuk menggu-
nakan tombol Tab ketika Anda menulis suatu outline, atau dari penomoran
ulang pada suatu daftar (list) ketika Anda menambahkan suatu poin di
tengah-tengah daftar tersebut. Tipe dokumen yang berbeda secara logis
memerlukan lingkungan daftar yang berbeda pula:

 Sebuah presentasi slide mungkin menggunakan lingkungan ltemize (Isit
berbentuk titik) merinci poin yang berbeda.

e Suatu outline mungkin menggunakan lingkungan Enumerate (list berben-
tuk dash) dan sublists berhuruf.

o Sebuah dokumen yang menjelaskan beberapa paket perangkat lunak
dapat menggunakan lingkungan Description, di mana setiap item dalam daf-
tar dimulai dengan kata tebal (bold).

o Lingkungan List adalah variasi pada lingkungan Description.

Mari kita menulis daftar alasan mengapa LyX lebih baik dari pengolah
kata lain. Di suatu tempat di dokumen Anda, ketiklah:

IyX lebih baik daripada pengolah kata lainnya karena:

kemudian tekanlah tombol Return atau Enter. Setelah itu di kotak lingkun-
gan pilihlah Bersimbol. LyX membuat satu baris kosong “bersimbol.” Cobalah
ketikkan alasan-alasan ini:

Pengaturan format diatur secara otomatis
Pengetikan Rumus Matematika merupakan WYSIWYG
Penulisan berbagai daftar sangat mudah dilakukan!

Lingkungan List tidak seperti lingkungan yang lainnya yang akan berakhir
ketika Anda menekan tombol Return. Pada lingkungan ini Iy X akan terus
menganggap Anda meneruskan daftar yang Anda tulis. Apabila Anda ingin
menulis beberapa baris pada satu lingkungan bersimbol, Anda perlu menggu-
nakan pemisahan baris protected dengan cara menekan tombol Ctrl4+Return.



Nur Insani - nurinsani@uny.ac.id

2.6. ENVIRONMENTS 11

Apabila ingin keluar dari lingkungan daftar dan kembali ke lingkungan st An-
dar, Anda perlu menekan gabungan tombol Alt+P S.

Anda baru saja belajar menuliskan daftar dengan rapi. Sekarang An-
da perlu menjalankan KTEX untuk melihat tampilan hasil apabila dicetak.
Tapi sebelum itu, bagaimana jika Anda ingin daftar yang bernomor bukan
daftar bersimbol. Baiklah, mari kita coba; tAndai semua daftar yang Anda
inginkan ® kemudian gantilah kotak lingkungan menjadi Bernomor. Seketi-
ka semuanya akan bernomor. Apabila Anda menghapus atau menyisipkan
daftar, IyX secara otomatis akan menyesuaikan nomornya.

Silakan mencoba menggantikan daftar yang ada dengan tipe lingkun-
gan daftar lainnya, Description dan List, lihatlah perbedaannya. Kedua tipe
lingkungan daftar ini menganggap kata pertama adalah terminologi yang
didefinisikan dengan kata-kata berikutnya sampai akhir paragraf (sebelum
menekan tombol Return.) Pada lingkungan Description, terminologi akan di-
tulis dengan huruf tebal, sedangkan pada List terminologi ditulis dengan hu-
ruf yang biasa tetapi kemudian ada semacam spasi pemisah yang mirip hasil
“Tab™ dengan kata berikutnya. Yang perlu mendapat perhatian adalah
apabila Anda mempunyai terminologi yang terdiri dari lebih satu kata, An-
da harus menggunakan spasi protected (Ctrl4+Space) bukan spasi biasa, agar
kata-kata tersebut menjadi satu terminologi.

Latihan: Ubahlah penulisan daftar yang ada di berkas example_raw.lyx

Anda dapat menuliskan daftar bertingkat dengan penampilan yang menarik.

Salah satu contoh yang mudah dipahami adalah ketika Anda ingin menuliskan
daftar bertingkat untuk suatu bagan garis besar. Daftar bernomor dan
bersimbol mempunyai cara penulisan nomor dan simbol yang berbeda di
setiap tingkatan (sub-daftar). Cara pengaturan yang lebih detail nomor
atau simbol dalam lingkungan daftar dapat dipelajari dan ditemui di buku
Petunjuk Penggunaan. Anda juga akan menjumpai beberapa contoh daftar
bertingkat.

3Anda tidak akan bisa memilih simbol yang pertama kecuali pilihan Anda termasuk
paragraf sebelum daftar bersimbol. Hal ini juga terjadi ketika Anda memilih salah satu
subbab bernomor, Anda juga perlu memilih paragraf sebelumnya. Hal ini disengaja karena
sesungguhnya simbol atau nomor tergantung dari teks sebelumnya.

4Hasil dari pengatur format tab, yang bisa menyesuaikan dengan lebar kata terminologi
yang dipakai; bukan lebar tab yang kaku dan tidak bisa berubah seperti pada Tab mesin
ketik.
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2.6.3 Lingkungan kutipan: Quotation, Quote, Verse,
dan Kode-LyX

Ada dua jenis lingkungan kutipan yang bisa digunakan: yang pertama adalah
Quote untuk penulisan kutipan singkat dan yang kedua adalah Quotation un-
tuk kutipan kalimat yang panjang. Apabila ingin menulis program komput-
er menggunakan lingkungan Kode-LyX® yang mempunyai tipe huruf mesin
ketik; lingkungan ini adalah satu-satunya lingkungan I’X yang mengijinkan
Anda menggunakan spasi berganda untuk pengaturan indentasi kode pro-
gram yang Anda tulis. Apabila Anda ingin menuliskan dan menyunting sa-
jak, Anda bisa menggunakan lingkungan Verse. Untuk memisahkan stansa
sajak, gunakan Return, sedangkan untuk mengganti baris stansa gunakan
Ctrl+Return. Untuk memahami semua lingkungan yang ada di LyX, silakan
lihat buku Petunjuk Penggunaan. Di buku tersebut Anda akan dapat mem-
baca semua penjelasan dan penggunaan lingkungan yang ada di LyX.

Latihan: Cobalah gunakan lingkungan Quote, Kode-LyX, dan Verse dalam
berkas latihan Anda example_raw.lyx.

Spada buku Tutorial ini digunakan untuk menulis contoh-contoh teks yang panjang



Nur Insani - nurinsani@uny.ac.id

Bab 3

Menulis Dokumen

Pada bab sebelumnya Anda sudah diperkenalkan menulis dengan IyX dan
harapan kami Anda sudah mulai terbiasa. Anda sudah diperkenalkan ten-
tang dasar penyuntingan dalam LyX, disamping juga diperkenalkan den-
gan lingkungan. Sebagian besar pemakai menggunakan yX untuk menulis
dokumen: makalah, artikel, buku, buku petunjuk, atau surat. Bab ini akan
meningkatkan kemampuan Anda dari sekedar menulis teks menggunakan
LyX menjadi mampu menulis dokumen yang lengkap. Disini Anda akan
diperkenalkan dengan class dokumen yang digunakan untuk menulis jenis
dokumen yang berbeda. Setelah itu Anda mempelajari bagaimana merubah
teks menjadi judul, catatan kaki, referensi silang, bibliografi serta daftar isi.

3.1 Class Dokumen

Dokumen perlu ditata secara berbeda tergantung dari jenis dokumen. Se-
bagai contoh, buku biasanya dicetak secara bolak-balik, sedangkan artikel
hanya dicetak di satu sisi kertas saja. Disamping itu, dokumen mempunyai
lingkungan yang khusus: dokumen surat - misalnya mempunyai lingkungan
untuk pengirim dan untuk tAnda tangan, yang tidak akan ditemui dalam
dokumen buku atau artikel. Class dokumen ! yang ada di IyX akan men-
gatur berbagai aturan penulisan yang ada untuk berbagai jenis dokumen.
Tutorial ini sebagai salah satu contoh, ditulis dalam class dokumen Book.
Berbagai jenis class dokumen yang ada merupakan salah satu bagian utama

luntuk pemakai BTEX: hal ini bermakna sama dengan BTEX document class

13
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dari filosofi WYSIWYM; class dokumen akan mengatur format aturan dalam
LyX, sehingga Anda tidak perlu melakukannya sendiri.

Sebelum ini, pada bab sebelumnya, Anda menggunakan class dokumen
yaitu Article. 2 Sekarang cobalah merubah dokumen latihan Anda ke class
dokumen yang lain (dari menu Dokumen>Pengaturan) untuk melihat adanya
perbedaan pengaturan. Apabila Anda merubah class dokumen menjadi Book
kemudian Anda periksa isi kotak Environment, Anda akan melihat bahwa
sebagian besar lingkungan yang tersedia sama. Namun demikian sekarang
Anda akan melihat lingkungan Chapter yang bisa Anda gunakan. Apabila
Anda tidak yakin tentang lingkungan yang dimiliki oleh suatu class dokumen,
Anda bisa melihat di kotak Environment.

Ukuran huruf, penulisan satu atau dua kolom, dan aturan heading ha-
laman adalah contoh beberapa aturan dan format penulisan yang berbe-
da dari satu dokumen ke lainnya. Dengan semakin matangnya dunia kom-
puter, beberapa penerbit Jurnal dapat menerima naskah secara elektronik,
dan menyediakan berkas TEX style yang dapat digunakan penulis untuk
menyusun naskahnya yang sudah mengikuti secara akurat aturan penulisan
yang dikehendaki jurnal tersebut. IxyX sudah dirancang untuk dapat men-
dukung sistem seperti itu juga. Sebagai contoh, LyX mendukung aturan
penulisan (juga lingkungan tambahan) untuk jurnal-jurnal terbitan Ameri-
can Mathematics Society dengan menggunakan class dokumen Article (AMS).

Tabel dibawah ini dapat Anda gunakan sebagai acuan ringkas dari beber-
apa class dokumen. Untuk mendapatkan informasi lebih terperinci, silakan
lihat pada bab Class Dokumen Khusus yang ada di buku petunjuk Fitur
Tambahan.

’ Nama Class \ Catatan ‘
article dicetak satu sisi, tanpa bab
article (AMS) tata letak & lingkungan untuk American Math Society
report lebih lengkap dari artikel, halaman bolak-balik
book report + lingkungan katagori frontmatter dan backmatter
presentation transparansi
letter berbagai lingkungan ekstra untuk alamat, tAnda tangan. ..

2Ini adalah class dokumen bawaan di LyX
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3.2 Templet: Menulis Surat

Salah satu cara untuk menulis surat adalah dengan membuka berkas baru,
kemudian dari menu Document> Settings kemudian pilih class dokumen Let-
ter. Walaupun cara ini merupakan cara yang benar untuk menulis surat
dari awal, tampaknya memerlukan waktu untuk menulis surat dari halaman
kosong. Setiap kali Anda ingin menulis surat, Anda harus menuliskan alamat
Anda, alamat yang dikirim, menulis isi surat, menulis nama yang bertAnda
tangan, dll. Untuk menyederhanakan proses penulisan surat, IyX menyedi-
akan templet untuk menulis surat, yang berupa contoh surat. Apabila Anda
sudah memiliki templet sendiri, maka sewaktu-waktu Anda ingin menulis
surat, Anda tinggal mengganti di beberapa bagian yang perlu saja.

Bukalah berkas baru dari menu File>New from Template, kemudian pil-
ihlah berkas templet letter.lyx. Simpanlah dengan nama lain kemudian
cetaklah untuk melihat berbagai lingkungan diatur.

Apabila Anda lihat di kotakEnvironment, Anda akan lihat berbagai lingkun-

gan yang berhubungan dengan surat, seperti misalnya lingkungan My Ad-
dress, yang tidak akan ditemui dalam class dokumen lainnya. Silakan Anda
mencoba berbagai lingkungan yang tersedia serta bagaimana hasil penulisan-
nya. Anda bisa lihat ada lingkungan Signature dengan kata “Tandatangan:”
yang berwarna merah sebelum teks sesungguhnya yang menyatakan nama
penanda tangan. Tentu saja kata “Signature:” tidak akan muncul dalam
surat yang dicetak, bila ditampilan melalui tampilan/pdf atau ekspor ke pdf.
Kata tersebut hanya sebagai petunjuk dimana Anda harus menuliskan nama
penanda tangan. Selain itu letak lingkungan juga tidak penting. Anda perlu
ingat bahwa Iy X adalah WYSIWYM; Anda bisa menempatkan lingkungan
Signature dimana saja, tetapi LyX mengetahui dimana lokasi menempatkan
tandatangan dengan tepat yaitu di bagian akhir.

Berkas templet sebenarnya berkas IyX biasa. Hal ini berarti Anda da-
pat mengisi alamat, tAnda tangan kemudian menyimpan sebagai templet
baru. Setelah ini, apabila Anda ingin menulis surat, Anda tinggal membuka
berkas templet Anda dan merubah seperlunya sehingga dapat menghemat
waktu penulisan surat. Untuk latihan menulis surat?; tulislah surat kepada

3Ada satu peringatan sewaktu Anda menulis surat menggunakan templet yang ada.
Apabila Anda menghapus semua teks di salah satu lingkungan — misalnya, apabila Anda
menghapus keseluruhan teks yang ada di lingkungan Alamat Saya dengan maksud akan
mengganti dengan informasi yang baru milik Anda sendiri — kemudian memindahkan
kursor ke lingkungan lain sebelum menuliskan informasi baru, maka lingkungan tadi akan
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seseorang menggunakan templet yang sudah adal

Templet akan sangat membantu Anda untuk menghemat waktu, kami
menyarankan untuk menggunakan templet apabila memungkinkan. Selain
daripada itu, berbagai templet dapat membantu Anda untuk mempelajari
bagaimana menggunakan berbagai class dokumen dengan variasi pengatu-
ran. Templet juga dapat membantu Anda untuk menyiapkan berkas LyX
yang akan digunakan untuk pemakai yang kurang dalam pemahaman kom-
puter atau kurang mengerti IyX. Bagi pemula akan lebih mudah mempela-
jari penggunaan LyX apabila ada contoh templet yang hanya memerlukan
merubah sebagian isinya saja.

3.3 Judul Dokumen

Dokumen di LyX (seperti juga IXTEX) selalu menggunakan halaman judul —
yang biasanya mengandung informasi judul sesungguhnya, penulis, tanggal,
atau abstrak dari suatu makalah — dipisahkan dari bagian isi dokumen.

Untuk memahami hal ini, silakan ke berkas Iy X Anda dan pastikan Anda
menggunakan class dokumen Article.* Ketiklah suatu judul pada baris perta-
ma kemudian ubahlah lingkungan baris yang Anda tulis judul ke lingkungan
Title. Selanjutnya pada baris berikutnya ketikkan nama Anda kemudian
ubahlah ke lingkungan Author. Pada baris berikutnya, tulislah tanggal dan
pastikan baris ini dalam lingkungan Date. Pada baris berikutnya gunakan
lingkungan Abstract kemudian tulislah beberapa kalimat, satu atau dua para-
graf. Anda bisa lihat bagaimana halaman judul ini ditampilkan bila dicetak,
melalui menu View> PDF(pdfiatex). Apabila Anda merubah class dokumen
menjadi Book, Anda akan lihat halaman judul akan terpisah, seperti pada
buku Tutorial ini.

Latihan: Ubahlah judul, penulis dan tanggal yang ada dalam berkas
latihan example_raw.lyx kedalam lingkungan yang tepat.

hilang. Hal ini karena lingkungan tidak bisa muncul tanpa adanya teks. Untuk mendefin-
isikan baru, pilihlah lingkungan Alamat Saya yang tadi hilang kemudian menuliskan infor-
masi yang Anda inginkan.

4Anda sekarang tidak lagi menggunakan class dokumen Letter, karena dalam class
dokumen Letter tidak memerlukan judul.
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3.4 Label dan Referensi-Silang

Anda dapat memberi label pada bagian yang masuk katagori SubBab, list,
rumus matematika, catatan kaki, dan kategori float® yang ada dalam doku-
men Anda. Setelah Anda memberi label, bagian lain dalam dokumen An-
da dapat mengacu pada bagian yang mempunyai label, dengan menggu-
nakan referensi silang. Anda dapat mengacu menggunakan nomor acuan
atau nomor halaman lokasi acuan. Apabila memilih nomor acuan, [yX akan
mengatur penomoran referensi-silang secara otomatis. Referensi-silang dan
pemberian nama label secara otomatis merupakan salah satu keunggulan
[xX (dan BTEX) daripada program pengolah kata lain.

3.4.1 Label Anda yang pertama

Anda perlu menggunakan berkas latihan yang sudah Anda kerjakan sebelum-
nya. Pergilah ke SubBab yang mempunyai judul “Tentang Dokumen Ini”.
Klik di akhir judul subbab ini, kemudian dari menu Insert>Label atau tekan
tombol bantuan . Jendela dialog akan muncul akan meminta Anda untuk
menuliskan nama label, dan memberikan saran nama. Apabila Anda mener-
ima saran nama label tekan tombol Setuju, nama label akan ditempatkan

dalam kotak disebelah judul subbab tadi.

Sebenarnya Anda diperkenankan meletakkan label di sembarang tempat
dalam judul yang Anda pilih; teks yang mengacu akan selalu mengacu pada
judul acuan terakhir sebelum acuan muncul. Namun demikian, meletakkan
label pada baris yang sama dengan judul subbab yang diberi label (atau
mungkin pada awal judul) akan meyakinkan bahwa acuan halaman akan
akurat pada judul yang diacu.

Sampai pada pemberian label Anda sebenarnya belum melakukan pe-
rubahan sesuatu — tampilan DVI belum ada perbedaan sama sekali, karena
label tidak akan muncul pada dokumen yang dicetak. Namun demikian,
Anda sudah mengerti bagaimana memberikan label yang dapat diacu meng-
gunakan referensi-silang. Selanjutnya kita akan pelajari bagaimana meng-
gunakannya.

SUntuk melihat yang termasuk dalam katagori SubBab dan list Anda dapat melihat
dari kotak lingkungan. Berbagai tipe float dijelaskan dalam buku Petunjuk Penggunaan
serta dalam buku petunjuk Obyek Tempelan .
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3.4.2 Referensi-silang Anda yang pertama

Masih menggunakan berkas latihan Anda, tempatkan kursor Anda di sem-
barang tempat pada subbab 2. Kemudian ketikkan

Apabila Anda ingin mengetahui lebih lanjut, silakan lihat
subbab, yang dapat ditemukan pada halaman.

Sekarang pindahkan kursor setelah kata “section” (subbab) kemudian dari
menu Insert > Cross Reference (referensi silang) atau gunakan tombol bantuan

W), Jendela dialog Cross Reference (Referensi-silang) akan muncul. Dalam
kotak dialog, Anda dapat melihat daftar label yang dapat diacu. Pada saat
ini tentunya hanya ada satu label, “sec: Tentang-Dokumen-Ini”. Pilihlah label
ini, kemudian tekan tombol Apply. Sekarang pindahlah kursor setelah kata
“halaman”, kemudian gantilah format acuan menjadi <halaman> kemudian
tekan tombol Apply. (Agar lebih rapi, Anda perlu menggunakan Spasi Pro-
tected antara kata “subbab” dan acuan referensi. Demikian pula setelah kata
“halaman” dan acuan halaman.)

Metoda lain yang bisa digunakan; Anda klik kanan pada label yang Anda
acu kemudian pilihlah menu Copy as Reference. Selanjutnya Anda dapat men-
empelkan di lokasi tertentu yang mengacu acuan dengan label yang sudah
dipilih, dengan menggunakan menu Edit> Paste (atau cara pintas Ctrl+V).

LyX akan menempatkan acuan dalam kotak tepat disebelah kanan dari
posisi kursor berada. Bila dokumen yang dicetak, tAnda kotak acuan terse-
but akan diganti dengan nomor halaman atau nomor subbab (tergantung
dari pilihan dalam kotak dialog Cross Reference). Cobalah melihat dokumen
dalam tampilan DVI, maka Anda akan lihat, kalimat yang Anda ketikkan
tadi dengan referensi silang sekarang tertulis “subbab 2”7 dan “halaman 1”
(atau sesuai nomor halaman dimana judul Subbab 2 berada ).

Referensi-silang juga berfungsi sebagai tautan ketika Anda melakukan
penyuntingan dokumen di Iy X; bila Anda klik di kotak acuan, dialog Cross Ref-
erence akan muncul, selanjutnya jika Anda menekan tombol Go to Label maka
kursor akan berpindah ke tempat label acuan berada.

3.4.3 Bermain-main dengan label

Tadi sudah dikatakan bahwa IxX mengatur secara otomatis penomoran
dalam referensi-silang; sekarang Anda boleh mencobanya. Tambahkan Sub-
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Bab baru sebelum Section (SubBab) 2. Perbarui tampilan DVI, maka —
Simsalabim! — nomor acuan referensi-silang berubah dengan sendirinya
menjadi “3”! Sekarang ubahlah Section yang berjudul “Tentang Dokumen
Ini” menjadi satu tingkat dibawahnya yaitu Sub-Section, sekarang bila Anda
lihat pada tampilan DVI yang sudah diperbarui, nomor acuan yang baru
menjadi 2.1 bukannya 3. Untuk halaman, tentu saja tetap tidak berubah
selama tidak ada penambahan halaman.

Apabila Anda ingin mencoba dan latihan menggunakan label, silakan
mencoba menambahkan label baru di tempat label pertama berada. Kemu-
dian di suatu tempat dalam dokumen, Anda mengacu pada label yang baru
Anda buat. Apabila Anda sering membuat label dan mengacu, akan lebih
mudah membiarkan jendela dialog Cross Reference tetap terbuka selama An-
da bekerja.

Latihan: Perbaiki acuan yang ada dalam berkas example raw.lyx

3.5 Catatan Kaki dan Catatan Tepi

Catatan kaki dapat dibuat dengan menggunakan tombol bantuan = atau
dari menu Insert > Footnote. Carilah kata “IyX” dalam dokumen latihan An-
da dan letakkan kursor setelah kata tersebut kemudian tekan tombol bantuan
[=. Kotak catatan kaki akan muncul untuk menuliskan teks informasi dalam
catatan kaki. [y X akan menempatkan kursor di dalam kotak penyuntingan
catatan kaki. Tulislah:

IyX adalah sebuah program pengatur dan penyunting dokumen.

Setelah selesai menulis, sekarang klik pada kotak dengan label “foot”. Kotak
penyuntingan catatan kaki akan tertutup, sehingga akan tinggal tanda berla-
bel “kaki” sebagai tanda adanya catatan kaki; ini disebut dengan “menyim-
pan” catatan kaki. Anda bisa membentangkan catatan kaki sewaktu-waktu
untuk penyuntingan teks catatan kaki dengan cara menekan kotak yang
mempunyai label “foot”.

Selain label “foot”, IiyX juga memberikan nomor. Nomor ini merupakan
nomor catatan kaki. Apabila Anda menyisipkan catatan kaki, maka nomor
ini akan secara otomatis disesuaikan. Anda dapat melihat tampilan berkas
DVI (atau hasil cetakan).
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Catatan kaki dapat disalin, dipotong dan ditempelkan seperti teks biasa.
Silakan mencoba! Anda hanya perlu menAndai kotak catatan kaki® kemudi-
an Cut dan Paste. Ada hal yang perlu Anda ketahui juga; Anda bisa merubah
teks menjadi catatan kaki setelah menAndai teks kemudian menekan tombol
bantuan [=. Untuk merubah catatan kaki menjadi teks bisa dilakukan den-
gan dua cara. Apabila kursor berada pada awal kotak penyuntingan catatan
kaki Anda bisa menggunakan tombol Backspace. Apabila kursor berada pada
akhir teks dalam kotak penyuntingan catatan kaki Anda bisa menggunakan
tombol Delete.

Catatan tepi dapat ditambahkan dari menu Insert>Marginal Notei atau

dari tombol bantuan E7. Catatan tepi sama dengan catatan kaki, kecuali
dalam beberapa hal:

» kotak penyuntingan catatan tepi mempunyai label “margin” bukannya
“foot”

o catatan akan ditempatkan di tepi dokumen yaitu pada batas halaman,
bukan dibawah dokumen

e catatan tepi tidak bernomor

Untuk percobaan, kembalikanlah catatan kaki untuk kata LyX menjadi teks
biasa, kemudian tandai dan buatlah menjadi catatan tepi. Jalankan IXTEX
(lihat berkas DVI atau PDF) untuk melihat bagaimana bentuk catatan tepi
ini.

Latihan: Perbaiki catatan kaki yang ada dalam berkas example_raw.lyx

3.6 Bibliografi

Bibliografi (dalam penerapan bidang sains) sebenarnya mirip dengan referensi
silang. Bibliografi mengandung daftar acuan yang dituliskan di bagian akhir
dokumen, dan daftar tersebut dapat diacu di teks dalam dokumen. LyX
dan BTEX membuat pekerjaan menjadi lebih mudah karena secara otomatis
mengatur nomor dalam daftar bibliografi serta merubah nomor acuan bila
ada perubahan dalam daftar bibliografi.

6 Akan lebih mudah menggunakan tombol papan ketik. Dengan tetikus mungkin secara
tidak sengaja Anda akan membuka ketika Anda menAndai kotak catatan kaki.
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Sekarang cobalah ke akhir dokumen kemudian merubah menjadi lingkun-
gan Bibliography. Setiap paragraf yang Anda tuliskan merupakan satu ref-
erensi. Tuliskan “The Lyx Tutorial, by the IyX Documentation Team”
sebagai referensi yang pertama. LyX secara otomatis menulis nomor dalam
kotak sebelum teks acuan. Apabila Anda klik kotak acuan akan muncul ko-
tak dialog Bibliography. Nama Key merupakan nama acuan dalam dokumen
LyX, sedangkan nama Label adalah yang akan muncul ketika dicetak. Apa-
bila tidak menggunakan Label (default), maka Anda akan melihat nomor
bibliografi dalam hasil cetakannya. Ubahlah nama Keyi menjadi “lyxtutori-
al” untuk mempermudah mengingat.

Kita akan mencoba untuk mengacu pada daftar acuan di Bibliografi. Dari
tempat teks akan mengacu ke daftar acuan, melalui menu Insert> Citation

atau dari tombol bantuan €. Selanjutnya dialog acuan akan muncul. Ko-
tak bagian kanan merupakan daftar semua bibliografi, dalam kotak ini An-
da diperbolehkan untuk memilih item bibliografi yang akan diacu. Pilihlah
“lyxtutorial” (saat ini, inilah satu-satunya item yang ada dalam bibliografi),
kemudian tekan tombol Add untuk memasukkannya (Anda boleh menggu-
nakan beberapa acuan pada satu tempat dengan cara menggabungkan be-
berapa kunci bibliografi yang ada di daftar kotak sebelah kiri dengan cara
ini.) Cobalah untuk melihat tampilan DVI, Anda akan melihat acuan den-
gan tanda kurung kotak yang mengacu pada bibliografi yang ada di akhir
dokumen.

Pengisian Text after dalam kotak dialog Acuan akan memberikan catatan
tambahan (seperti misalnya informasi halaman atau bab yang diacu dari
buku atau artikel dalam bibliografi) yang ditulis dalam tanda kurung kotak
setelah informasi acuan. Apabila Anda menginginkan acuan yang diiginkan
ditulis bukan dalam bentuk nomor acuan tetapi dalam bentuk label (mis-
alnya, dalam beberapa jurnal menggunakan “[Smi95]” untuk mengacu satu
artikel yang ditulis oleh Smith tahun 1995), maka Anda perlu mengisi nama
Label dalam dialog Bibliography.

Latihan: Perbaiki penulisan bibliografi dan acuan yang ada dalam berkas
example_raw.lyx

3.7 Daftar Isi

Anda tentunya ingin menambahkan daftar isi di bagian awal dokumen. Dalam
LyX pembuatan daftar isi dilakukan dengan mudah dan sederhana. Yang
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Anda perlukan adalah tekan tombol papan ketik Return setelah lingkungan
Titlel tetapi sebelum Bab (Chapter) atau SubBab (Section) yang pertama,
kemudian pilih menu Insert>List / TOC> Table of Contents. Setelah itu akan
muncul kotak dengan tulisan “Table of Content (Daftar Isi)”.

Tampaknya kotak ini tidak memuat daftar isi yang Anda harapkan. Na-
mun demikian, apabila Anda melihat tampilan berkas DVI, Anda akan meli-
hat daftar isi yang sesungguhnya sudah ada, mengandung semua Bab, Sub-
Bab yang ada dalam dokumen Anda. Apabila ada perubahan dalam doku-
men Anda, kemudian Anda memperbarui tampilan DVI, maka perubahan di
daftar isi akan secara otomatis mengikuti perubahan.

Bawaan awal dari LyX, daftar isi secara lengkap tidak ditampilkan di
layar Anda. Namun demikian jika Anda menginginkan melihat daftar isi,
Anda dapat menampilkan di jendela Outline dengan cara menekan tombol

bantuan paparan isi Q, atau dari menu Documentr>Outline. Pemaparan
isi disini akan menampilkan daftar isi dari dokumen Anda walaupun Anda
belum memerintahkan daftar isi (dari menu Insert> Table of Content). Dari
jendela Outline, Anda dapat melakukan navigasi dokumen dari satu bagian
ke bagian lainnya dengan mudah. Anda hanya perlu klik di judul-judul
yang ada dalam jendela Outline, kursor akan berpindah ke lokasi judul yang
Anda pilih dengan akurat. Anda juga bisa menggunakan tombol panah
dari papan ketik untuk berpindah naik dan turun dalam jendela Outline.
Untuk memudahkan Anda, jendela ini bisa tetap dibiarkan aktif selama Anda
menulis atau menyunting di jendela kerja Anda. Fungsi melihat isi dokumen
serta navigasi bisa juga Anda lakukan dari menu Navigate, dimana daftar isi
akan ditampilan secara otomatis melalui menu ini.

Untuk menghapus daftar isi dari dokumen Anda, Anda hanya perlu meng-
hapus kotak Table of Content (Daftar Isi) yang ada di awal dokumen, seperti
cara menghapus satu simbol yang ada dalam teks.

Latihan: Perbaiki daftar isi yang ada dalam berkas example_raw.lyx
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Bab 4

Menggunakan Rumus
Matematika

Salah satu alasan I¥TEX banyak digunakan oleh para saintis adalah karena
dapat menghasilkan rumus matematika yang sangat rapi dan bagus, tan-
pa menggunakan berbagai kombinasi karakter yang biasa dipakai di berba-
gai program pengolah kata atau program penyunting rumus matematika.
Namun demikian banyak juga saintis yang kesulitan menggunakan KETEX
karena menulis persamaan matematika bagaikan menulis program komput-
er, bukannya menulis biasa. Dengan menggunakan IX kesulitan tidak akan
terjadi, karena LyX mempunyai fasilitas WYSIWYM untuk penulisan rumus
matematika. Apabila Anda biasa menggunakan I¥TEX, semua kebiasaan An-
da menuliskan rumus matematika masih Anda gunakan seperti biasa, namun
apa yang Anda tuliskan akan berubah dalam tampilan WYSIWYM. Apabi-
la Anda belum pernah mengenal bagaimana menulis persamaan matemati-
ka dalam KTEX, berbagai tombol bantuan yang ada di kotak bantuan Ru-
mus Mate-matika akan membantu Anda menyusun rumus matematika den-
gan mudah dan akan mempunyai tampilan hasil yang profesional.

4.1 Lingkungan Rumus Matematika

Sekarang coba ketikkan di berkas latihan IyX Anda:

Saya mengerti rumus Einstein, E=mc”2, karena sangat mudah.

23
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Anda dapat lihat sendiri, rumus yang Anda tulis tidak nampak rapi, baik di
layar maupun tampilan hasilnya. Dikatakan tidak rapi karena tidak mem-
punyai spasi antara variabel demikian pula dengan tAnda sama de-ngan.
Demikian pula tAnda pangkat 2 tidak tertulis diatas seperti bagaimana t An-
da pangkat yang kita kenal. Tidak rapinya rumus yang Anda tulis dikare-
nakan Anda tidak mengatakan kepada IyX bahwa rumus yang Anda tulis
merupakan rumus matematika, sehingga LyX masih menganggap bahwa ru-
mus tadi adalah teks biasa.

Sekarang kita akan lihat bagaimana seharusnya menulis rumus matem-
atika dengan benar. Untuk memulai menulis rumus matematika, tekanlah
tombol bantuan %2 atau bisa juga dari menu Insert>MathInline Formula.
LyX akan memunculkan lingkungan rumus matematika, berupa kotak kecil
berwarna biru yang masih kosong. Cobalah menulis dalam lingkungan ru-
mus matematika yang masih kosong tersebut dengan E=mc~2. Tulisan dalam
lingkungan rumus matematika akan berwarna biru, setelah Anda memulai
menulis sesuatu, kotak biru akan hilang. Untuk keluar dari lingkungan ru-
mus matematika gunakan tombol papan ketik Esc. Anda akan lihat bahwa
kotak berwarna ungu hilang dan kursor berada di sebelah kanan ekspresi
matematika yang sudah Anda tulis. Ini menAndakan kursor sudah berada
pada lingkungan teks stAndar sehingga Anda bisa melanjutkan penulisan
teks atau penyuntingan selanjutnya.

Untuk melihat hasilnya, kita perlu menjalankan KTEX untuk menampilkan
hasil. Tekanlah tombol bantuan /<. Anda akan lihat sendiri rumus matem-
atika yang Anda tuliskan terlihat cantik, ada spasi antara variabel serta
tAnda sama dengan, demikian pula tAnda pangkat diatas baris “2” akan
tampak rapi. Dalam lingkungan rumus matematika, huruf dikenal sebagai
variabel dan ditulis dengan huruf miring, sedangkan untuk angka ditulis
dengan huruf biasa bukan huruf miring.

Penyuntingan rumus matematika merupakan salah satu contoh dari filosofi
WYSIWYM. Apabila Anda menggunakan perintah TEX biasa, misalnya
Anda akan menuliskan suatu ekspresi matematika yang mengandung akar
menggunakan perintah \sqrt; kemungkinan Anda akan menemui kesulitan,
karena Anda tidak biasa melihat bagaimana ekspresi tersebut sampai An-
da menjalankan ETEX untuk melihat tampilan hasil. Kesulitan lain adalah
apabila ingin mencari lokasi penambahan tAnda kurung yang masih belum
lengkap. IyX tidak menampilkan rumus matematika secara WYSIWYG
dengan sempurna, namun akan memberikan gambaran bagaimana tampilan
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hasil yang Anda inginkan. I¥TEX lah yang kemudian akan mengatur secara
profesional tampilan hasil akhirnya.

4.2 Penulisan Rumus Matematika

Sekarang kita akan merubah rumus yang sudah ditulis £ = mc? menjadi

E = 1+ mc?. Caranya adalah gunakan tombol panah di papan ketik ke tem-
pat dalam lingkungan rumus matematika yang akan ditulis. Apabila kursor
masuk dalam lingkungan rumus matematika, maka tAnda kotak warna un-
gu akan muncul yang menAndakan Anda berada dalam lingkungan rumus
matematika dan siap untuk melakukan penyuntingan. Gunakan panah Kiri
dan Kanan ke sebelah m kemudian tuliskan “14-”. Untuk keluar dari lingkun-
gan rumus matematika Anda dapat menggunakan tombol Esc.

Penyuntingan dalam lingkungan rumus matematika sama dengan proses
penyuntingan teks biasa. Anda bisa menggunakan Delete (atau Backspace)
untuk menghapus, demikian pula Anda bisa memilih, memotong, menyalin
atau menempel atau membatalkan penyuntingan dengan Edit>Undo. Yang
perlu mendapat perhatian adalah: apabila kursor Anda berada tepat di kiri
kotak lingkungan rumus matematika, kemudian Anda menggunakan tombol
Delete, maka Anda akan menghapus kotak bersama seluruh isinya. Demikian
pula bila kursor tepat diluar sebelah kanan kemudian Anda menekan tombol
Backspace, kotak dan isinya akan terhapus. Namun bila hal tersebut tidak
Anda kehendaki, Anda bisa mengembalikannya dengan Edit>Undo.

Bagaimana seandainya Anda menginginkan merubah £ = mc? menjadi

E = mc®® + 1?7 Sekali lagi kami ingatkan, Anda gunakan tombol panah
seperti yang kami sarankan tadi, atau Anda bisa juga menggunakan tetikus
Anda untuk menempatkan kursor ke lokasi yang Anda kehendaki. Apabila
kursor berada tepat setelah “c” dan sebelum angka “27, tekanlah tombol
panah keatas (Up). Kursor akan bergerak ke baris atas (subscript), sebelum
angka “2”. Seteleh itu tulislah “.5”. Sekarang tekanlah tombol spasi, maka
kursor berpindah ke baris utama lagi, kemudian Anda bisa menuliskan “+17.
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4.3 Penulisan Pangkat dan Indeks Baris (Sub-
script)

Penulisan pangkat dalam lingkungan rumus matematika dapat dibantu den-
gan salah satu tombol di kotak bantuan matematika (berada di bawah jen-
dela kerja IyX), atau dapat dengan cara sederhana dan cepat yaitu meng-
gunakan tombol papan ketik “7”. LyX akan menampilan kotak biru di baris
atas, superscript. Disinilah Anda dapat menuliskan pangkat yang mempun-
yai ukuran huruf lebih kecil. Setelah selesai menuliskan pangkat, Anda keluar
dari lingkungan pangkat tetapi masih dalam lingkungan rumus matematika
dengan cara menekan tombol Space. Apabila ingin langsung keluar dari
lingkungan rumus matematika Anda perlu menekan tombol Esc.

Untuk menuliskan indeks di baris bawah, subscript, ada cara yang mu-
dah juga. Gunakan tombol garis bawah di papan ketik, “ “ Dengan cara
penulisan pangkat dan indeks baris yang sudah kami jelaskan Anda pasti
bisa menulis rumus matematika seperti ini: A, 52 + Cao+b?,

Latihan: Ubahlah persamaan 1 di example_raw.lyx dengan penulisan
rumus matematika yang benar.

4.4 Kotak Bantuan Matematika

Math toolbar (kotak bantuan Matematika) disediakan untuk memudahkan
Anda menuliskan atau menyunting persamaan matematika. Berbagai macam
penulisan rumus juga dapat dilakukan dari menu Edit>Math atau Insert>
Math. Namun demikian sekarang kita akan melihat penggunaan Math tool-
bar, apa saja yang bisa Anda lakukan. Untuk penggunaan cara pintas tidak
dibahas sekarang, Anda bisa membacanya di buku petunjuk lainnya.

Kotak bantuan matematika ini akan muncul secara otomatis bila kur-
sor berada dalam lingkungan rumus matematika, serta dapat dimunculkan
secara manual dari menu View> Toolbars. Apabila kemudian Anda memil-
ih “Matematika (otomatis)” maka kotak bantuan matematika akan selalu
muncul di bawah layar kerja Anda, dan menu “Matematika (otomatis)” akan
diberi tAnda centang. Apabila Anda menekan sekali lagi maka tanda cen-
tang akan dihilangkan dan kotak bantuan matematika akan kembali pada
kondisi otomatis, artinya kotak bantuan matematika hanya akan muncul
apabila kursor berada di dalam kotak lingkungan rumus matematika.
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4.4.1 Huruf Yunani dan Simbol

Math toolbar menyediakan bantuan untuk menuliskan berbagai simbol yang
sering digunakan untuk menuliskan rumus, seperti: huruf yunani, tanda
panah, relasi matematika, operator, diferensial dan integral. Ada hal yang
perlu Anda ketahui adalah untuk menuliskan batas bawah dan batas atas
dari integral dan jumlah sigma Anda dapat menggunakan bantuan baris
bawah (subscript) dan baris atas (superscript).

“Tidak ada yang tidak bisa dilakukan... Anda hanya memerlukan ©.

4.4.2 Akar, Simbol Dekorasi, dan Simbol Pembatas

Untuk menuliskan akar, tekan tombol akar di kotak bantuan di bawah jen-
dela kerja ¥O. TAnda akar akan muncul dan kursor akan berada dalam
kotak penyuntingan. Anda bisa menuliskan variabel, angka, tAnda pangkat
lainnya, pembagian, atau apa saja yang Anda perlukan untuk menuliskan
rumus matematika. IyX akan secara otomatis menyesuaikan ukuran simbol
akar agar sesuai dengan keperluan yang ada di dalam tAnda akar.

Cara pemberian simbol dekorasi untuk suatu variabel, misalnya ', atau
kelompok beberapa variabel seperti a 4+ b dilakukan dengan prosedur yang
sama seperti menulis akar. Untuk dekorasi, Anda juga perlu memilih deko-
rasi terlebih dahulu dengan menekan tombol bantuan 7. Setelah Anda
memilih salah satu simbol dekorasi, LyX akan menampilkan kotak biru kosong
tempat penyuntingan beserta dekorasi pilihan Anda. Ada dua tipe dekorasi
yang bisa Anda lakukan: yang pertama adalah dekorasi yang besar dan
panjangnya mengikuti rumus yang ada di dalam dekorasi, dan yang kedua
adalah dekorasi dengan ukuran tetap yaitu bila digunakan hanya untuk satu
variabel saja.

Simbol pembatas matematika seperti tAnda kurung biasa, kurung ku-
rawal atau berbagai tipe tAnda kurung yang rumit lainnya dapat dilakukan.
Pengaturan tAnda kurung secara umum dapat dilakukan dengan menekan
tombol [l untuk memunculkan dialog Delimiter (pembatas matematika). An-
da dapat melihat berbagai tipe pembatas dalam kotak dialog. Pilihan awal
adalah t Anda kurung biasa yang sama untuk batas kanan dan kiri. Anda bisa
memilih pembatas yang Anda inginkan serta Anda juga bisa mengatur kom-
binasi pembatas kiri dan kanan sesuai kehendak Anda, misalnya “a = (77
(pembatas kosong atau “tidak ada” pembatas akan muncul dalam jendela
kerja IyyX dalam bentuk garis putus-putus, namun tidak ada dalam tampi-
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lan hasil yang sesungguhnya).

Simbol pembatas dapat Anda ketikkan langsung dalam lingkungan ru-
mus matematika tanpa melalui dialog Delimiter. Namun demikian pembatas
yang Anda ketikkan manual akan mempunyai ukuran sesuai dengan ukuran
teks standar sehingga tidak akan sesuai apabila digunakan sebagai pembatas
pembagian atau matriks. Untuk pembatas kiri kanan yang sesuai dan mam-
pu menyesuaikan dengan isi, kami sarankan Anda menggunakan salah satu
dari tiga tombol sisipan pembatas yang ada, misalnya Anda bisa menekan
tombol pasangan () yang ada di kotak bantuan matematika.

Anda dapat menambahkan pembatas, tanda akar atau simbol dekorasi
pada rumus matematika yang sudah ada. Caranya adalah dengan memilih
bagian rumus yang Anda inginkan untuk ditambah, kemudian tekan tombol
dekorasi atau tAanda pembatas, atau tanda akar di Math Toolbar. Cobal-
ah untuk merubah rumus hukum kedua Newton yang sudah ditulis dalam
bentuk skalar menjadi vektor (f = ma menjadi f = m@). Setelah Anda
mempelajari penulisan matriks, Anda dapat melakukan penambahan tanda
kurung matriks dengan cara yang dijelaskan disini.

4.4.3 Pembagian

a
Untuk menuliskan pembagian, tekan tombol pembagian b di Math Toolbar.
LyX akan menyediakan dua kotak penyuntingan yang dipisahkan garis pem-
bagian. Seperti yang mungkin sudah Anda duga, Anda bisa menggunakan
tombol tanda panah di papan ketik Anda untuk memindahkan lokasi kur-
sor Anda, atau Anda juga bisa menggunakan tetikus untuk menempatkan
kursor di lokasi pembagian yang Anda inginkan. Cobalah klik tetikus An-
da di kotak atas dan ketik angka “1”, kemudian tekan tombol papan ketik
dengan tAnda panah kebawah atau Down kemudian ketik angka “2”. Anda
telah menulis pembagian! Tentu saja Anda bisa menulis rumus matematika
di dalam dua kotak pembagian yang ada: variabel dengan pangkat, tanda
akar, pembagian lainnya, rumus matematika apa saja.

Latihan: Tuliskan persamaan 2 yang ada di berkas example_raw.lyx
dalam lingkungan rumus matematika.
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4.4.4 Fungsi Matematika: Limit, log, sin dan lainnya

Huruf yang Anda tuliskan dalam lingkungan rumus matematika akan dike-
nal sebagai variabel, apabila Anda mengetik “sin” dalam lingkungan Math
(rumus matematika), [yX akan mengira bahwa yang Anda ketikkan adalah
gabungan dari tiga variabel s, 7, dan n. Oleh karena itu tiga variabel tersebut
akan dituliskan dengan huruf miring, padahal sesungguhnya yang Anda in-
ginkan adalah satu kata dari fungsi matematika “sin” dan seharusnya ditulis
dengan huruf Roman. Selain dari hal tadi, yX akan menambahkan spasi
setelah menuliskan kata “sin” dan “x” (bila menekan tombol Spasi akan
keluar dari lingkungan rumus matematika). Jadi bagaimana Anda dapat
menuliskan “sin(z)” bukannya “sin(z)”?

Gunakan tombol “n di Math Toolbar kemudian pilih “sin” dari daftar
yang ada. Kata “sin” akan ditampilkan IxX dengan warna hitam, dan
mempunyai huruf tegak dari tipe huruf roman. Kata ini akan dikenal se-
bagai satu simbol, sehingga bila Anda menghapus dengan tombol Backspace,
maka langsung terhapus satu kata sekaligus, bukan hanya satu karakter.
Setelah memilih “sin” teruskan mengetik “(x)”, yang ditulis dengan huruf
biru dan dalam huruf miring, seperti pada rumus matematika. Hasil tampi-
lan setelah menjalankan KTEX, penulisan tadi akan rapi dan cantik. Silakan
mencobanya.

Fungsi matematika yang ada termasuk semua fungsi trigonometri dan
kebalikannya, fungsi hiperbolik, fungsi logaritma, limit, serta berbagai fungsi
lain. Fungsi yang ada dalam daftar, semuanya dapat mempunyai tambahan
baris atas (superscript) atau baris bawah (subscript), sebagai contoh untuk
penulisan “cos? 67 atau “lim,_..".

Latihan: Tuliskan persamaan 3 di berkas example_raw.lyx menggu-
nakan cara penulisan yang benar dalam lingkungan rumus matematika.

4.4.5 Matriks

Tekan tombol bantuan &% di Math Toolbar. Anda dapat menentukan jumlah
baris dan dan kolom dari jendela dialog matriks yang muncul. Pilihlah 2
baris dan 3 kolom kemudian tekan Setuju. LyX akan menampilkan 6 ko-
tak penyuntingan untuk matriks orde 2 x 3. Seperti yang kami jelaskan
sebelumnya, Anda dapat menuliskan ekspresi matematika di setiap kotak
penyuntingan (termasuk tAnda akar, matriks lainnya, dll.). Apabila Anda
tidak ingin mengisi kotak juga tidak menjadikan masalah, dan hasil tampilan
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akan kosong.

Disini tombol papan ketik Tab dapat digunakan untuk memindah kursor
pada arah horisontal yaitu bergerak dari satu kolom ke kolom lainnya. Anda
juga dapat menggunakan tombol panah yang ada di papan ketik - tombol
panah ke kanan (Right) akan memindahkan kursor ke kotak berikutnya di
sebelah kanan, tombol panah ke bawah (Down) menggerakkan kursor ke
kotak berikutnya yang ada di baris bawahnya, demikian panah lainnya akan
menggerakkan kursor sesuai dengan tAnda panah.

Apabila Anda ingin merubah jumlah baris dan kolom, gunakan menu Ed-
it> Rows & Columns atau dari tombol bantuan di kotak bantuan matematika
e 3, WY

Pengaturan lebih lanjut bagaimana perataan horisontal di setiap kolom,
serta bagaimana merubah posisi vertikal matriks dapat dibaca di buku Petun-
juk Penggunaan. Perlu mendapat perhatian Anda, apabila Anda ingin menu-
liskan tabel yang berisi informasi teks, Anda perlu menggunakan fasilitas
tabel yang disediakan [yX, jangan mendefinisikan tabel menggunakan ma-
triks.

4.4.6 Rumus Matematika Dalam Mode Display

Semua cara penulisan rumus matematika yang dijelaskan sebelumnya adalah
tipe rumus matematika inline, yaitu rumus matematika ditulis pada baris
teks. Hal ini biasa dituliskan bila rumus ini tidak terlalu panjang. Namun
demikian, apabila Anda ingin menuliskan rumus yang panjang atau ingin
menuliskan rumus secara terpisah dari teks dan ditulis pada baris tersendiri
maka Anda perlu menulis rumus dalam mode display. Anda juga perlu
mengerti bahwa hanya rumus dalam mode display yang bisa diberi label dan
nomor persamaan (lihat buku Petunjuk Penggunaan). Selain itu, bila Anda
menginginkan rumus yang terdiri dari beberapa baris (multi-line), hanya
dapat dilakukan pada mode display.

Untuk memulai penulisan rumus display tekan tombol bantuan =, yaitu
tanda kotak biru diantara baris teks diatas dan dibawah, yang ada di Math Tool-
bar. LyX akan menyisipkan tempat formula pada baris yang baru, dan berada
di tengah baris. Cobalah menulis pada mode display ini kemudian jalankan
ETEX dengan menampilkan hasil pdf. Tombol mode display ini sebenarnya
tombol pengaturan yang bisa digunakan untuk merubah tipe rumus inline ke
rumus display atau sebaliknya. Cobalah sekarang ke salah satu rumus yang
sudah Anda tuliskan kemudian tekan tombol mode display ini, dan amati
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perubahannya, kemudian tekanlah kembali. Anda tentunya sekarang jelas
bagaimana memanfaatkan tombol ini.

Ada beberapa perbedaan rumus display dengan rumus baris (inline):

« Pada beberapa simbol seperti }_ dan [, ditulis dengan st Andar ukuran
yang lebih besar.

« Batas bawah dan batas atas pada jumlah sigma )", dituliskan di bagian
bawah dan bagian atas simbol sigma. Untuk fungsi limit, batas ditulis
di bawah simbol limit, sedangkan untuk pada rumus baris tertulis di
sebelah tAnda limit.

e Rumus ditulis di tengah baris

Selain dari hal yang dijelaskan diatas, penulisan rumus baris dan rumus
display pada dasarnya sama saja.

Salah satu hal penting yang perlu Anda catat adalah mengenai penga-
turan setelah rumus display: Anda harus memahami benar apakah setelah
rumus display merupakan paragraf baru atau tidak. Apabila rumus display
berada di tengah suatu paragraf, maka Anda jangan menekan tombol Return.
Jika Anda melakukannya, maka teks setelah rumus display akan menjadi
awal paragraf baru, sehingga kata pertamanya akan masuk kedalam karena
adanya identasi awal paragraf. Kemungkinan hal ini tidak Anda kehendaki.

Latihan: Ubahlah rumus-rumus dalam berkas example_raw.lyx men-
jadi rumus display, dan perhatikanlah bagaimana hasilnya menjadi berbeda.

Latihan: Dengan menggunakan berbagai tombol bantuan yang sudah
Anda pelajari sampai saat ini, Anda tentunya dapat menulis persamaan
mate-matika seperti dibawah ini ':

logg x x>0

5 1

1Setelah Anda mencoba yang mungkin tidak mudah, cobalah menulis persamaan tadi
dari menu Insert>Math > Cases Environment
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4.5 Berbagai Pengaturan Rumus Matemati-
ka

Sebenarnya masih banyak lagi pengaturan rumus matematika yang bisa di-
lakukan dalam IyX. Untuk sementara ini, Anda sudah menguasai dasar
pengaturan yang ada. Pengaturan lanjutan dapat Anda pelajari dari buku
Petunjuk Penggunaan. Anda akan temui berbagai petunjuk tentang:

o Pemberian label dan nomor persamaan.
o Persamaan dalam lingkungan baris berganda (Multi-line equations).

e Perubahan jenis huruf dalam persamaan, misalnya merubah menjadi
teks dengan huruf tebal.

o Perubahan ukuran huruf, serta pengaturan spasi dalam rumus. (bi-
asanya Anda memerlukan ini untuk penyelesaian dan pengaturan draf
terakhir!)

e Penulisan dan penyusunan program makro. Hal ini sangat bermanfaat,
Anda hanya perlu mendefinisikan di awal dokumen, kemudian dapat
digunakan di seluruh dokumen sampai akhir.

o Berbagai macam pengaturan yang belum perlu dibahas dalam Tutorial
ini.
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Lain-Lain

5.1 Fitur Utama LyX

Sampai bab ini, kita belum membahas secara tuntas semua fasilitas yang
dapat dimanfaatkan dari IyX. Seperti biasanya yang bisa kami katakan
adalah, silakan membaca buku User’s Guide (Petunjuk Penggunaan) serta
buku petunjuk Embedded Objects (Obyek Tambahan) untuk mendapatkan
penjelasan terperinci dan lengkap. Disini kami hanya paparkan beberapa
hal penting yang ada dalam IyX:

o [xX mempunyai pengaturan tabel yang bersifat WYSIWYM. Gunakan
menu Insert > Table (tombol bantuan ®) untuk pengaturan tabel. Apa-
bila Anda klik tombol kanan dalam sel tabel, Anda dapat menemukan
Table Settings yang memunculkan jendela dialog untuk penyuntingan
tabel. Selain itu bila apabila kursor Anda masuk pada salah satu
sel tabel, maka secara otomatis akan muncul kotak bantuan tabel di
bawah jendela kerja [y X. Kotak bantuan otomatis akan hilang dengan
sendirinya bila kursor tidak berada dalam sel tabel.

o [xX juga dapat melibatkan gambar dari berbagai format masuk dalam
dokumen. (Anda bisa menebak: dari menu Insert> Graphics (tombol
bantuan ) Kemudian Anda cari berkas gambar yang akan dima-
sukkan, Anda bisa juga memutar atau mengatur skala, dll.) Apabila
tabel dan gambar merupakan obyek float, dari Insert> Obyek Float, Iy X
akan memberi nama tabel atau gambar secara otomatis.

33
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o IxX dapat diubah sesuai keinginan pengguna. Segala sesuatu yang
ada di LyX mulai dari bagaimana tampilan jendela kerja LyX sampai
bentuk tampilan output dokumen dapat diatur dengan berbagai cara.
Sebagian besar pengaturan konfigurasi dapat dilakukan dari Toolsr
Preferences. Penjelasan lebih lanjut, silakan lihat di Help > Customization.

o LyX dikembangkan oleh tim gabungan dari lima benua. Oleh kare-
na itu, LyX sangat mendukung berbagai bahasa selain bahasa Ing-
gris (seperti Belanda, Jerman, Perancis, Yunani, Turki, Indonesia,. . . )
lebih dari dukungan bahasa di program pengolah kata yang lain. Bahkan
bahasa dengan sistem penulisan dari kanan ke kiri seperti bahasa Arab,
Persia, Hibrani serta bahasa dari Asia yang mempunyai huruf rumit
seperti Cina, Jepang dan Korea juga didukung. Anda dapat menulis
dokumen dalam bahasa pilihan Anda dan Anda juga bisa merubah
menu yang ada di [yX sesuai bahasa pilihan Anda.

o Menu yang ada di LyX mempunyai berbagai kunci ikatan yang akan
mempercepat akses ke menu. Hal ini berarti bahwa Anda dapat men-
gakses menu Filer> Open dengan cara menekan Alt+e kemudian menekan
tombol B atau langsung menggunakan cara pintas yang tertulis disebe-
lah menu (untuk membuka berkas baru, Ctrl4+0). Kunci ikatan ini dap-
at diubah. Penjelasan terperinci dapat dibaca dari Help > Customization.

o [xX dapat membaca dokumen ETEX. Silakan lihat di bab ?77.

» Pemeriksa ejaaan, padanan kata, serta fasilitas statistik seperti penghi-
tungan kata semuanya tersedia.

» Fasilitas pembuatan indeks, nomenklatur atau daftar istilah juga ada
di LyX.

5.2 IyX untuk pengguna ETEX

Apabila Anda belum tahu sama sekali tentang KTEX, Anda tidak harus
membaca bagian ini. Namun demikian jika Anda ingin mempelajari IXTEX,
silakan teruskan membaca bab ini. Bagi yang sudah mengenal IXTEX dan
sekarang akan menggunakan IyX, Anda mungkin akan bertanya apakah
yang Anda lakukan di KTEX bisa juga diterapkan di IxX. Jawabannya
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ringkas saja; [yX dapat menjalankan hampir semua yang bisa dikerjakan
BTEX dan akan menyederhanakan sebagian besar perintah IXTEX.

Buku ini bukanlah sekedar tutorial, kami akan membahas beberapa hal
yang mungkin akan menarik perhatian bagi yang baru menggunakan [yX.
Namun demikian, agar buku Tutorial ini ringkas, untuk sementara kami
hanya memberikan penjelasan yang sederhana. Buku petunjuk Additional
Features (Fitur Tambahan) dan Embedded Objects (Obyek Tempelan) dap-
at membantu Anda mempelajari lebih lanjut berbagai penjelasan tentang
perbedaan Iy X dan IXTEX, serta berbagai teknik dan trik BTEX untuk dit-
erapkan di LyX.

5.2.1 Perintah TEX

Semua perintah TEX yang Anda ketikkan di dokumen akan diteruskan lang-
sung ke KTEX, serta akan ditampilkan di layar kerja dengan warna merah.
Untuk menuliskan perintah TEX dalam berkas [3X gunakan Insert> TEX Code
(tombol bantuan Te¥). Perintah yang Anda tuliskan dalam kotak inilah yang
diteruskan ke KTEX.

Dalam menuliskan rumus matematika (Insert>Math formula atau dari
tombol bantuan aTw), pada dasarnya menggunakan perintah TEX tetapi LyX
mengaturnya dengan cara berbeda. Apabila menggunakan sisipan perintah
TEX, Anda perlu menuliskan perintah TEX seperti biasanya yaitu menggu-
nakan backslash, tetapi bila menggunakan rumus matematika semua perintah
backslash tidak akan dimunculkan, hanya semua rumus yang Anda tuliskan
akan dikenali dengan warna biru. Setelah selesai menuliskan perintah TEX
kemudian mengetik Spasi atau karakter selain huruf, seperti angka, atau
garis bawah, maka secara otomatis akan berubah menjadi MYSIWYM. Se-
bagai contoh, apabila Anda mengetik “\gamma” dalam lingkungan rumus
matematika ((Insert>Math formula atau dari tombol bantuan %°) kemudian
menekan Spasi, IxyX akan merubah perintah yang Anda ketikkan “\gam-
ma” berwarna merah akan menjadi yang Anda maksudkan yaitu “y” dan
berwarna biru. Hal ini akan berlaku pada hampir semua makro matematika
yang ada. Bagi para pemakai KTEX yang biasa menuliskan perintah makro
matematika dapat bekerja lebih cepat daripada menggunakan Math Toolbar.

Ada satu kasus khusus dalam lingkungan rumus matematika, apabila
Anda mengetik tanda kurung kurawal pembuka dalam program TEX, maka
otomatis tanda kurung pembuka dan tanda kurung penutup akan muncul
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dengan warna merah, kemudian secara otomatis akan keluar dari mode pro-
gram TEX. Dengan cara ini akan memudahkan menuliskan perintah I¥TEX
yang LyX tidak mengetahui dimana memerlukan informasi argumen dari su-

atu perintah KTEX.

ILyX tidak bisa melakukan semua yang dapat dilakukan dalam KETEX,
terutama fungsi yang berkaitan dengan berbagai fancy yang sifatnya tamba-
han, atau tidak semuanya WYSIWYM. Dalam hal ini TEX Code merupakan
media untuk menerapkan dan menggunakan semua fleksibilitas yang ada di
ETEX dalam lingkungan IiyX yang mempunyai kemudahan dalam penulisan
rumus matematika, tabel serta fasilitas lain yang sifatnya WYSIWYM. Anda
bisa juga memanfaatkan semua paket BTEX yang ada, dengan menuliskan
misalnya \usepackage{foo} dalam preamble (lihat bab 5.2.3.2) — walaupun
untuk ini Anda tidak menemui fitur WYSIWYM.

5.2.2 Konversi Berkas Iy X ke ETEX

Apabila Anda ingin menyimpan berkas IyX ke berkas KTEX, misalnya Anda
ingin mengirimkan ke mitra kerja atau mitra penulis yang tidak memiliki
Ly X tetapi memahami IXTEX, maka Anda perlu mengkonversi [yX ke IXTEX.
Caranya adalah dari menu Filer> Export > LaTeX(plain). Proses ekspor ini akan
menghasilkan berkas whatever.tex dari berkas whatever.lyx yang sedang
Anda sunting. Sebenarnya IyX selalu membuat berkas sementara dalam
format IXTEX sebelum menampilkan hasil atau mencetak berkas LyX.

5.2.3 KETEX Preamble
5.2.3.1 Class Dokumen

Berbagai pengaturan dokumen dilakukan dari menu Document> Settings.
Dialog Class Dokumen sama halnya dengan perintah IXTEX \documentclass.
Selain dari pemilihan class dokumen dan perubahan ukuran huruf, pengat-
uran ukuran kertas serta batas kertas juga dilakukan dari dialog pengat-
uran dokumen. Apabila Anda ingin menambahkan perintah tambahan di
\documentclass ada fasilitas untuk menuliskan perintah tersebut, dari ko-
tak Own Setting.
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5.2.3.2 Penulisan ETEX Preamble

Bagi yang biasa menggunakan IXTEX, seringkali Anda menambahkan perin-
tah tertentu yang berada di bagian Preamble dari berkas IXTpX. Anda masih
bisa menambahkan perintah di Preamble dalam IxX. Caranya adalah dari
menu Document > Settings > KTEX Preamble kemudian ketikkan perintah yang
Anda inginkan dalam kotak yang tersedia. Semua perintah yang ada disi-
ni akan dikirim langsung ke EIEX yang didefinisikan sebagai bagian dari
ETEX Preamble.

5.2.4 BibTEX

LyX mempunyai fitur untuk BibTEX yang memungkinkan Anda meman-
faatkan basis data referensi bibliografi BibTEX untuk digunakan dalam LyX.
Caranya adalah dari menu Insert> List / TOCw BibTEX Bibliography kemudian
memilih berkas yang berisi basis data BibTEX. Anda mempunyai kelelu-
asaan memuat berkas BibTEX yang Anda gunakan, demikian pula Anda
boleh memilih gaya tulis BibTEX pilihan Anda.

Setelah Anda memuat berkas basis data BibTEX, Anda akan bisa men-
gacu ke isi basis data dari menu Insert > Citation (lihat subbab 3.6). Di kotak
dialog Acuan Anda akan melihat semua data referensi dari berkas BibTEX
yang sudah Anda muat. LyX akan mengatur sistem acuan.

5.3 Pesan Kesalahan (Errors)!

Kadang-kadang ketika Anda menuliskan perintah IXTEX dalam dokumen,
terjadi kesalahan, sehingga baik LyX ataupun IXTEX tidak bisa mengenal
atau menjalankan perintah yang Anda definisikan. Apabila kasus seperti
terjadi LyX akan membuka jendela dialog ETEX Errors. Dengan cara meng
klik pesan kesalahan yang ada di dialog, akan membawa Anda ke tempat
teks dalam berkas [yyX Anda yang menyebabkan kesalahan terjadi. Pada
dialog tersebut akan ada penjelasan detail dari pesan kesalahan KTEX.
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